PDA

View Full Version : ATI Catalyst 6.3 available



Treetop64
03-13-2006, 05:09 PM
Downloaded it last night, and noticed considerable increases in performance in regards to framerates.

It seems that in an effort to make sure their hardware is available this time around when they say it will be, ATI may have put the cart in front of the horse by releasing the X1900 series before the software to manage it was up to snuff. Cat 6.3 fixed a lot of the issues I was having with some of my older games, which initially, actually ran worse than with the previous card installed (X1800XL). Specifically, GTR exibited much slower performance until 6.3 was installed.

On the other hand however, the newer games just ran that much better (CoD2, FEAR, Quake 4), and PF 4.04m now runs like silk in 1200 x 1000 in Perfect mode. I'll run the numbers tonight with a FPS check from the console, but I'm feelin' pretty good about what I'll see. Maybe I get the 60s to high 90s average? Hope so...

papotex
03-13-2006, 05:41 PM
newer games just ran that much better (CoD2, FEAR, Quake 4), and PF 4.04m now runs like silk in 1200 x 1000

mine already run like silk at that resolution
with the x850 pe

LUFT11_Hoflich
03-13-2006, 06:05 PM
I got an "old" Radeon 9600 128Mb, shluld it be worth for me to DL the drivers?

Thanks..
H¶f... http://forums.ubi.com/images/smilies/51.gif

Treetop64
03-13-2006, 06:09 PM
Originally posted by LUFT11_Hoflich:
I got an "old" Radeon 9600 128Mb, shluld it be worth for me to DL the drivers?

Thanks..
H¶f... http://forums.ubi.com/images/smilies/51.gif

Go to the ATI website, and look up the drivers downloads for the operating system you use. They contain ReadMe info that you can peruse before you download, and the info includes specifically which cards will benefit.

JadehawkII
03-13-2006, 07:17 PM
Funny, 2 weeks ago I downloaded the Catalyst 6.2 and screwed up my monitor settings. I could not fix anything as it had broken up the view into 5 different pieces!
So I deleted everything in relation to the Catalyst 6.2 and loaded up the one that came with my new X1800XL and things are fine again.
I'm not too excited about trying to update my Catalyst again after that epsiode I had.

VMF-214_HaVoK
03-13-2006, 07:29 PM
6.3s have been out for a week or so now. I cant believe I have not tried them yet. Im having great success with the DH Zeropoint drivers based on 6.2s.

Treetop64
03-13-2006, 08:41 PM
Originally posted by JadehawkII:
Funny, 2 weeks ago I downloaded the Catalyst 6.2 and screwed up my monitor settings. I could not fix anything as it had broken up the view into 5 different pieces!
So I deleted everything in relation to the Catalyst 6.2 and loaded up the one that came with my new X1800XL and things are fine again.
I'm not too excited about trying to update my Catalyst again after that epsiode I had.

I had the X1800XL. It's an excellent card, especially for what you pay for it. The drivers that come on the CD seem ideally suited to the architecture of that card's layout. I never bothered to download drivers when it was installed, as it performed quite ably with the stock software.

vocatx
03-13-2006, 09:14 PM
I got a nice little boost in fps on my X800 with the 6.3 drivers. They're well worth giving them a try.

JG52Uther
03-14-2006, 01:19 AM
Originally posted by vocatx:
I got a nice little boost in fps on my X800 with the 6.3 drivers. They're well worth giving them a try.
Same here,installed them last night.