View Full Version : Last Assasin's Tomb in Venice (Contextual Camera)

12-10-2009, 11:10 PM
Im in the Tomb with the 4 buttons on the floor that activate the hanging switches. I'm getting a constant contextual camera view of my goal (floor button or hanging switch) that I can't turn off. So I am unable to look in the direction that I need to move and am so forced to move and jump blind. Is this a glitch or am I missing something?

12-14-2009, 02:48 PM
I had the same problem in that level and elsewhere. The camera gets a very limited range of motion when you're in a tight space, it can be very frustrating on the platforming levels.

Annoying during fights too, but not as difficult as with the platforming scenes.

01-15-2010, 10:46 AM
I had the same problem - it was freaking maddening! In desperation, I tried pushing and PULLING all the controller buttons. It turns out the L2 button was "stuck" in the housing slightly, leaving it barely pushed in to activate the contextual camera. So, pull the L2 button out a bit (tug on the bottom of it) and see if that helps - it worked for me.

01-15-2010, 07:33 PM
I've played through four times and each time--usually in tombs--had the same issue with the camera being "stuck" in such a way as to hinder my ability to move Ezio in the right way. I don't think it's the L2 (PS3) button being stuck; it's just the way it was programmed. The developers seemed to want to keep us focused on where Ezio was to go next, but didn't take into account how annoying it is.

07-12-2010, 06:55 PM
I had the same problem too. I just re-mapped the camera to a button that I don't use and all worked fine. Playing on a PC with and Xbox Wireless Controller.

07-13-2010, 04:05 AM
Yep. Hate the stupid contextual camera. I just pressed the arrow keys (PC, keyboard and mouse) and hoped and jumped.