PDA

View Full Version : X52 loss of control while in flight



voyager_663rd
01-01-2009, 03:09 PM
Relating for a friend: I've searched on 15 pages but can't find a reference although I'm sure I read about this.

While flying, in a bank turn all control is lost. <span class="ev_code_RED">It's not a stall.</span>: the x52 stops responding as if it's forgotten what it's supposed to do.

References to this anywhere?

Urufu_Shinjiro
01-01-2009, 05:50 PM
This may sound silly but sometimes the cord between the stick and throttle comes loose, check for that. Also a uninstall and reinstall of drivers and sst might be in order if that hasn't been tried already.

TX-EcoDragon
01-01-2009, 11:01 PM
Originally posted by Urufu_Shinjiro:
This may sound silly but sometimes the cord between the stick and throttle comes loose, check for that. Also a uninstall and reinstall of drivers and sst might be in order if that hasn't been tried already.


Yep, one of my early X-45s had a flaky cable between the throttle and stick - it had intermittent connection issues, even though it would only drop for a second, IL-2 would then ignore the stick after that until I would exit and rejoin.

voyager_663rd
01-02-2009, 08:18 AM
He's tried the wiggly cable issue (I now remember having to unplug and replug it myself now that you mention it).

I'll remind him. Had an issue with the "new" sst with my "old" profile. He reloaded the old sst and got it working but still had the drop outs.

He mentioned when going into the programming, it was primarily an X-axis issue-->only giving him about 100% movement one way/ the other side only 60-70% movement or nothing at all mid point in a mission.

Thanks! (anyone else, don't hesitate to add http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif ).

Urufu_Shinjiro
01-02-2009, 09:19 AM
When he went back to the old SST did he go back to the old driver as well? They don't work well if you mismatch them. Also, when he gets the lopsided X axis, is this in windows game controllers screen?

voyager_663rd
01-02-2009, 12:42 PM
I believe he used the new drivers with the old sst because it was only with the old sst that he could use my 'old' stick profile--I have to check.

"in windows game controllers screen?" yes

voyager_663rd
01-04-2009, 01:18 PM
Originally posted by Urufu_Shinjiro:
When he went back to the old SST did he go back to the old driver as well? They don't work well if you mismatch them. Also, when he gets the lopsided X axis, is this in windows game controllers screen?

He gets reduced X-axis in both windows and saitek controller screens.

He is going to uninstall and try both old/old and new/new software/profile and report back. There may be a conflict here; the stick itself may also have issues.

Bearcat99
01-05-2009, 04:31 PM
There's always depends...

(Sorry... I just couldn't help it.... http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif http://forums.ubi.com/images/smilies/88.gif)

voyager_663rd
01-06-2009, 05:38 PM
You should be sorry. http://forums.ubi.com/groupee_common/emoticons/icon_rolleyes.gif

In any case, I believe he thinks the saitek x52 is a piece of excrement and should be incinerated.

Luckily, mine is perfect but after you read the pages and pages of complaints people have about it, it's a wonder that any actually work. You don't believe me, go to the saitek forums and read about it.