View Full Version : Sequence 8 Issues-cannot continue

11-17-2010, 05:56 PM
I'm at sequence 8, memory 5, "Seeing Red." I start the memory, walk to the highlighted area, and nothing! When I pause, it says, "Current Objective: Press any button." I press every single button on the controller, and nothing! I cannot use anything but the apple, cannot call my horse, cannot change memories, etc. Any tips? I'm supposed to be breaking up Cesare's meeting with the cardinals, but nothing's happening. PLEASE HELP!

11-17-2010, 06:07 PM
Hi coolcadet! I'll pass this along but until then I'd suggest contacting support with your issue. Also, what system are you playing on? http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

11-17-2010, 06:14 PM
This is on the Xbox 360. Also, I have tried restarting the console several times, and that has not worked. Thank you!

11-17-2010, 10:55 PM
same problem here

11-17-2010, 11:38 PM
You can't do anything else when you carry the apple, it says that in the weapon wheel. You need to go to the highlighted area and do Eagle vision (will that work for you?). You need to find the Cardinal in that area and follow him inside the Colosseum (I think it explains itself after that fairly well).

11-18-2010, 12:15 AM
Is this the green circle when you need to find the Cardinal? I walked around that green circle for minutes, nobody was there, then all of a sudden, I turn a corner, the same corner I walked past like twice moments earlier, and there the Cardinal was standing there. O_o

Weird, but, it worked. (I actually got on a horse that was chilling right outside the area, walked the perimeter with the horse, and that's when the Cardinal showed up)

11-18-2010, 11:37 AM
The Cardinal is to the left of the longest rectangle building when looking from the map. I was confused as to why he didn't show up when I got to the green circle, then just about fell on him. He is in bright red so he can't be missed