View Full Version : No investigation markers in Memory Block 4, Damascus.

11-18-2007, 04:21 AM
Ok, so I'll explain everything I've done so far.
I spoke to Al Mualim, who told me I could go to either Damascus, Acre or Jerusalem.
I chose Damascus.
When I arrived there, the first thing I did was climb all the view point, save all the citizens and do the informer quests.
After all of those were done, I went to the Assassin's Bureau.
He told me stuff about the mission and told me that I had to investigate.
Now comes the problem : There are no investigation markers anywhere on the map.
I climbed all the view points and saved all the citizens so please don't tell me I should do those.
I think the problem is that I should have went to the Bureau first and then do all the view points, etc.
But there is no mention anywhere that I will get stuck if I don't.
I also know that there have been alot of topics much like this one, and they have ALL been discarded by saying, you must have done something wrong.
So please, if you have anything helpfull to tell me, do that and don't say : 'climb the viewpoints and they should show up'.

Thanks in advance.

11-18-2007, 04:24 AM
Try leaving the city and then go back, maby that will help. Or just choose the memory block 4 when you are in the animus and do it again.

11-18-2007, 04:32 AM
You might have climbed all the viewpoints in one district, maybe the poor district, which is the first one, however you may have never entered the rich district. To see where viewpoints are you must first of all scale a viewpoint and synchronize, the map will then reveal all the other view points in the said district allowing you to gather information for the hit.

11-18-2007, 04:35 AM
go to the rich district, climb a tower and then suicide

11-18-2007, 04:40 AM
Go to the next district and climb those towers. The map will open.

11-18-2007, 05:02 AM
Hey i no what the problem is. same thing happened with me and talal. Bascially i did two investigations then went to the burough. then the only thing i could do was high points, save citizens, and the assassination, i couldnt do any more investigations. Basically i just did the assassination and i will go back to that mission at the end, (think u can redo missions when done with the story) so that i can get that achiment. Just kill the guy and go to the next city!

11-18-2007, 06:30 AM
HOLY! I Have The EXACT Same Problem! Glad To See Its Not Just Me!

Here's The Situation:
I'm Stuck In Poor District. I Climbed All The View Points, Rescued All The Civilians, Yet The Map Won't Reveal Anything!

I Went To Rich District, Found A Civilian And Rescued Him, Nothing. Found An Intergation Too, Nothing.

Did The Same In Middle District AND STILL NOTHING! No Other View Points I Can Visit To Reveal The Rest Of The City! Nothing! I Probally "Could" Continue The Game.. But I Have No Idea Where Anything Would Be! (Or Where To Go) There Has To Be A Fix For This...

Also, In Memory Log It Says I Have Done 0/6 View Points Within The Poor Destrict... WTF?

Edit: It's Happening In Acre Too, Forgot To Mention That :P

11-18-2007, 06:39 AM
I knew there were others with the same problem as me.
It has to be some sort of bug/glitch, developing screwup, because things like this shouldn't happen.
I haven't tried all the things that were mentioned above yet, but I highly doubt they work, unless the person that stated it had the same problem I do.
And Dav3Th3Rav3 tried them, and it didn't help him either..
If I don't see any good solutions within this day, then I'll be forced to start the game over again.

11-18-2007, 07:28 AM
so if you entered the city for the first time, climbed all the viewpoints in the 1st district your allowed in and then wwent to the assassins berough thing...you wouldnt be able to pinpoint the investigations within that district? pretty dumb thingy to overlook during the testing stages :S

11-18-2007, 07:31 AM

If you pull up your map it says climb a view point to reveal missions w/e.

So you go find a view point that borders the next district NOT a view point in the middle of the district you just complete all the missions in.

The view points won't be given to you so it's your job and by now to know what view points look like. Just look around and find the ones that border the memory glitch or overlook next district.

11-18-2007, 07:33 AM
Just in case my post was overlooked, IF YOU HAVE DONE AN ASSASSINATION IN A CERTAIN DISTRICT, YOU WILL NOT HAVE TO DO ANYTHING THERE AGAIN. Move on to the next district. Climb a view point THAT YOU FIND (they dont show them at first anymore) and then things will pop up on the map.

11-18-2007, 08:15 AM
*******it, I Feel Stupid Now.

At First, When You Guys Said "Go Into Rich District, Then Climb A Viewpoint" I Thought "I Can't If I Don't Know Where They Are!"

But.. As Mentioned Before.. Since Your A Little Farther In The Game I Guess, You Have To Find The Viewpoint YOURSELF. Damn.. I Just Did That In Jerusalem And It Worked. Bravo! Now I Can Continue The Game!

There Should Be A Stickie Or Something For Noobs.. Or At Least In-Game Tell The Players That "Oh, Well, Find The Damn Thing By Yourself!" Thanks For The Help Guys! Now I Can Continue! =D

11-18-2007, 09:55 AM
I'm pretty sure they mention something about it...it didnt take me any time to figure it out while playing.

11-18-2007, 09:59 AM
Its ok i was stumped myself for a little while i was thinking wtf what am i supposed to do now then realised.