View Full Version : No Insurgency Pack after 1.04 patch

06-24-2010, 03:18 PM
I have had installed the Insurgency pack since its release and now that I have auto applied the 1.04 patch none of the new maps are listed

Anyone else got this problem?

06-24-2010, 03:49 PM
Tried that several times. Restarted the game, everything. Tried entering my serial number again and it told me it had already been used, went back to Deniable Ops and they were there.

Weird, still least I got em back

06-25-2010, 01:35 AM
Everything was good after applying this patch yesterday. But today I can't find DLC maps too. And I can't enter multiplayer and even unlockable menu, because Ubisoft servers is inaccessible.

It looks like we've got this problem because of servers. But I'm not sure.

P.S: I think, that it's true, all of this happened because of servers and DRM issue. By the way, my DLC levels are already back.

06-26-2010, 07:44 AM
It happens to me as well. It's totally random. I just restart the game and most of the time it will work...

06-26-2010, 10:26 AM
EDIT: Now I'm having the same problem as everyone else in this thread. The maps aren't there even though they're supposed to be.