View Full Version : Waves=3 in PF? Performances issues for perfect mode

10-25-2004, 12:56 PM
Could anyone tell me what I need to change in the conf.ini file to get some nice waves effects in PF? I got a 6800 Ultra and I already changed the water=3 for both OpenGL and DirectX. No matter what, I always a flat sea surface with a kinda mirror effect.
Also, I have to play in 'Excellent' mode and cannot use the 'Perfect' mode for the landscape otherwise I got something like 2fps. My computer is a phase-change cooled P4 running 4Ghz and my 6800 Ultra is watercooled running at 475Mhz (instead of 400) so it shouldn't be related to a weak computing power. And yes, my AGP aperture is set to 128Mb.


10-25-2004, 12:59 PM
I think it's water=3. And IIRC the waves are dependent upon wind speed and weather conditions.

10-25-2004, 01:02 PM
Oups, yes, I meant water=3, sorry.
Hey, I'll try with some wind then maybe.

10-25-2004, 01:14 PM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Originally posted by S1rkillalot:
Oups, yes, I meant water=3, sorry.
Hey, I'll try with some wind then maybe. <HR></BLOCKQUOTE>

If that's the case, on the readme it's said you can't have 3d water with the 61.77 series, being 65.73's currently recomended.
For your other perfect fps issue there might be something very wrong on your setup, as most top end card from the previous generation can run perfect with water=1 over 20fps in with a fast cpu at 1024 (with some concessions on AF and Aniso of course!).
You should head on to the Tech Help Forum and post your dxdiag were with some luck you'll find detailed help.

10-25-2004, 01:16 PM
Your video configuration HAS TO BE LIKE THIS:

1) 32bit color
2) OpenGL, *NOT* DirectX
3) Stencil Buffer ENABLED
4) last, but certainly not least, 'Perfect' quality settings and *NOT* 'Excellent'

This *WILL* give you the water effect you describe, trust you me.

10-25-2004, 02:46 PM
U guys rock !!! http://forums.ubi.com/images/smilies/heart.gif
I installed the new Forceware 66.81 WHQL, set OpenGl then Landscape perfect with water=3 and now I got absolutely georgous waves effects. I even set 3DGunners on I got great fps with AA4x/AF4x. The forest=3 is a bit too much for confort for my rig though when I am flying over the land, but well, difference between forest=2 and 3 is almost invisible.
Thanks a million to you all!

10-25-2004, 03:49 PM
What does this function "3DGunners on" do and where is it located?

10-25-2004, 04:12 PM
3dgunners=1 in the [game] section of the conf.ini. Documented in the readme.rtf. Add 3D characters at the AA guns and others. Look like this:

10-25-2004, 04:48 PM
In your setup, set landscape to excellent, then go into config ini under openGL and set HardwareShaders=1. It will look awsome and still be highly playable.

10-25-2004, 06:02 PM
Is running OpenGl the only way to get this 'shiny' water ?

OpenGL the preferred choice over Dx for this game ? I've not yet tested.

I have a 9800XT