PDA

View Full Version : Microphone



danjama
05-19-2009, 06:11 PM
I have a headset, with seperate ports for the ears and mic.

The problem im having is a strange one.

Outside of the game, my microphone works perfectly, volume is fine, voice sounds fine, works nice in TS.

As soon as i start the game up, i get a huge amount of reverb/feedback where all i can hear is my own voice. The effect is multiplied once i am on an airfield, almost as if the noise of my voice is bouncing off the map.

So far i have tried all of the in game settings and none had any effect, but it's obviously something with the game becuase the mic is perfect outside of game.

Any ideas? I'm hoping it's a simple adjustment in the conf.ini....

will also add that when i disable sound the microphone goes back to normal.

danjama
05-19-2009, 06:11 PM
I have a headset, with seperate ports for the ears and mic.

The problem im having is a strange one.

Outside of the game, my microphone works perfectly, volume is fine, voice sounds fine, works nice in TS.

As soon as i start the game up, i get a huge amount of reverb/feedback where all i can hear is my own voice. The effect is multiplied once i am on an airfield, almost as if the noise of my voice is bouncing off the map.

So far i have tried all of the in game settings and none had any effect, but it's obviously something with the game becuase the mic is perfect outside of game.

Any ideas? I'm hoping it's a simple adjustment in the conf.ini....

will also add that when i disable sound the microphone goes back to normal.

MAXMHZ1959
05-19-2009, 06:22 PM
conf.ini:

[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=8
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=0
MasterVolume=14
<span class="ev_code_YELLOW">Attenuation=7</span>

That should do it.

Check your sound mixer too. Maybe it has settings to suppress feedback and/or microphone amplification/Attenuation.

danjama
05-19-2009, 08:15 PM
Hello mate i tried changing that setting to many values and none had any effect whatsoever, still this huge echo.

However here is an interesting development. When i turn off enhancements/hardware acceleration from setup, the feedback goes away. However, i then have to put up with poor sound and crackling http://forums.ubi.com/images/smilies/51.gif

There must be a way to have my cake and eat it (enhancements/accel AND good mic quality in game).

Thanks for trying though!

FoolTrottel
05-19-2009, 11:55 PM
Go to the windows Volume settings.

If the 'Mic' is not visible there, goto Options, Properties, and Check the 'Microphone' in the Playback list. (Yes, 'Playback') Press Ok.

Make sure the Microphone is Muted in the volume settings.

MAXMHZ1959
05-20-2009, 01:59 AM
You did not mention echo before http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

Run DXDiag; Start - Run - type dxdiag click OK

Select the Sound tab

Drag the Hardware Sound Acceleration slider to the left until it says Basic or Standard.

The crackling sound may be a symptom of IRQ conflict(s). Check here (http://www.webtechgeek.com/How-to-Resolve-IRQ-Conflict.htm) on how to check and resolve this.


Reverberation, Feedback and Echo are all very different sound properties.

Sorry if it sounds a bit pedantic.

Good Luck!

danjama
05-21-2009, 08:31 AM
Hi mate thanks for suggestions. No change, after changing them settings.

As for the conflicts, none to do with my audio, but found this http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif

http://i11.photobucket.com/albums/a194/danjama/untitled-2.jpg

no idea what to do, doesn't seem to have any negative effect on computer.

I tried to reinstall drivers without connecting to net and it was a no go, so i don't want to mess my PC up, it's running sweet.

KG26_Alpha
05-21-2009, 02:43 PM
Insert the CD that came with the Motherboard and install the necessary drivers.

10/100 Lan drivers

Chipset drivers

If you don't have the OEM Mobo CD&gt;

Look at the mobo and between the ram slots and CPU or in between the white PCI slots you should find the motherboard Type and version .

Visit the manufacturers website and download the drivers.

You must be running a wireless or PCI network adapter as the motherboards native Lan is US.

Re: Poor sound quality.
The Mods do induce crackling and sometimes poor &lt;spacial&gt; sound especially if your using onboard sound of a lesser quality.

Good Luck

danjama
05-21-2009, 05:32 PM
Hey thanks Alpha i have all the docs for the Mobo i made the PC myself, still have the drivers, but i have updated the BIOS a long time ago, will installing the drivers interfere with anything?

I am running wireless also.

Also, i have an audigy 2 installed, which is alot better than onboard sound http://forums.ubi.com/images/smilies/16x16_smiley-sad.gif

So should i install original drivers?

KG26_Alpha
05-22-2009, 12:49 PM
Hi

Flashing the bios won't affect the system drivers, and vice versa, unless there are updated drivers at the manufacturers website for the updated bios version you are using.

You are best to download the drivers from thier website as they could have newer ones than the CD version that came with the Mobo.

As for "interfering" there shouldn't be a problem as these drivers are unrelated directly to sound card installation, but should have an effect on the mobo's efficiency as you are missing the chipset drivers, these help the mobo's components talk to each other (simply put), so indirectly it could affect the sound quality.

Once you have the motherboard up to date you can start to debug the sound, at the moment there's not much point as these critical drivers are missing.

Good Luck

danjama
05-24-2009, 03:15 PM
Hey Alpha just saying thanks for your advice, got the new mobo drivers installed and the errors have gone, and thanks for welcoming me on comms http://forums.ubi.com/images/smilies/25.gif