PDA

View Full Version : Joystick stopped working in IL2 1946..need advice!



drsmith
06-06-2011, 05:14 PM
I have a Microsoft Sidewinder Force Feedback 2 joystick that has always worked perfectly with all my flight sims. It works fine with Flight Simulator X, Combat Flight Sim 2, B17 and Falcon 4.0. No problems.

But after having not played IL2 1946 for awhile, I find that my joystick is totally usless...a dead fish in the water. I have checked the settings, clicked Joystick "ON", checked the Menu Settings in controls, hardware and difficulty. My Conf file shows Joystick set on 1. But no joystick control whatsoever in the game. It works so well with the other flight sims...it seems there is some correction I need to make in IL2 1946 but I have tried everything I can think of to solve this problem but am getting nowhere. I start the game with Stab but that has never been a problem before. Please help solve this problem, thanks.

Woke_Up_Dead
06-06-2011, 05:56 PM
Hey Dr. Smith, in all your recent technical problems that you mention in this forum you talk about the Stab. How about trying to get rid of it/disconnect it/not start the game through it?

I have the same joystick as you, and it never gave me problems with this game, stock or modded. I never tried Stab though.

If I were in your place, I would be very methodical about it: either make a checklist of things that you added to the game and try turning them off one-by-one to see which one is screwing things up for you; or better yet start with a new basic installation of the game and add things to it to see which one makes your joystick stop working. Once you find what is causing the problems, then you can either not use it, or know for certain which area you need to concentrate on to fix.

drsmith
06-08-2011, 07:21 AM
Thanks for your reply, Woke Up Dead. I will disable Stab, although I hate to play the game without the authentic markings. But I'd rather play the sim without markings than not be allowed to play the sim at all. Why a computer decides to change settings I'll never know.

Whether I will recover joystick control with Stab disabled is a crapshoot. I'll soon find out. Sadly, IL2 1046 was installed, by a computer genius friend who is no longer available, along with many missions that were added and if I uninstall to start over I will surely loose a lot of the game I like so much.

I am a Doctor of Dental Surgery and know just enough about computers to be extremely dangerous. I mainly avoid but sometimes tip-toe through downloads, installs, uninstalls, upgrades and add-ons for fear of screwing things up...which I usually do.

I think I did solve the scrambled icons due to resolution changes by right clicling on Recycle Bin and selecting Save or Restore Desktop Icons. This seems to work for me.

btasm
06-08-2011, 02:11 PM
Just a thought. 1.make sure joystick is plugged in before starting Il2 and 2. Try creating a new pilot to see if the JS works with him. Sometimes the settings.ini in mine gets messed up or doesn't match the pilot I am using.

drsmith
06-08-2011, 03:36 PM
Thanks, Guys...joystick is plugged into computer. Created a new pilot. I disabled Stab...but I can't get the game to start unless Stab is enabled and I click on the Stab "Start" icon. Just inserting the IL2-1946 disc and clicking the IL2 pop up window won't start the game. I guess I could remove Stab from the computer, but I don't want to do that unless absolutely necessary. I feel there is a setting somewhere that will fix this problem since the joystick works perfectly with all the other games. Once the game starts through Stab, I get a beautiful widescreen cockpit view and ablsoutely no imput of controls with joystick, no speed, X,Y,Z control...nothing. The only way I can stop he flight is Ctrl/alt/delete and back to desktop. At least my desktop icons are no longer scrambled.

Woke_Up_Dead
06-08-2011, 05:53 PM
Have you tried starting the game directly from your hard-drive rather than from the DVD? Look in your IL-2 directory (probably C:/Programs/Ubisoft/IL2-1946, or something like that), and look for the executable file, I think it's called FB.exe and will be represented by an icon resembling the game startup page with the F4U. Double-click it, see if the game starts.

Also, try to remember exactly what you did on your computer (maybe not even related to the game) between the last time your joystick worked, and the first time it didn't.

Tully__
06-09-2011, 07:16 AM
Do you have another controller plugged in that wasn't plugged in the last time your joystick worked? If so, it may have taken the place of your joystick. Unplugging the other controller or re-assigning joystick axes in the controls screen will fix it if this is the case.

drsmith
06-12-2011, 10:08 AM
Thanks for the input, guys! I noticed some of my key settings in Controls were not what they used to be...so I started re-setting the keys as I remembered them to be. Don't recall setting any key related to joystick, but, SUDDENLY I had control again of the joystick. I have no idea what did to gain control again of the joystick but I'll accept whatever happened. Now the game works perfectly, as it once did. Ahh, Computers!