View Full Version : Stuck after whare house alarms are set

11-28-2009, 06:22 AM
So I set them then go into the part were I chase the target into the round tower and can't get higher than the balcony. I can't grab the beam above for some reason. Any clues?

11-28-2009, 07:46 AM
Welcome to the forums http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

When you're on the balcony you sit directly infront of the beam and jump up and Altair will grab it http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

11-28-2009, 07:50 AM
I think I have tried that. I spent over an hour in that scene until and thought I have tried everything.

11-28-2009, 07:55 AM
Did you try it from the ledge ?

11-28-2009, 09:41 AM
Have you not seen the Dream Sequence workaround thread? Go there.

11-28-2009, 01:44 PM
I figured it out. He wouldn't jump and grsb from anywhere so I ran next to the door and jumped left and grabbed it.

And no I couldn't find the dream sequnce thread, although I didn't know what it was caled either.

Thanks for all your help.