View Full Version : Trapped in sequence 6-7 (possible spoiler)

11-21-2009, 07:59 PM

I'm trapped in the dream sequence(assassin's creed 2) where you play as altier chasing the woman in assassins' garb. She enters the tower and closes the door so you must climb the tower.

I can climb up to a balcony, and on that balcony is a wood post coming out from above the door with a lantern on it.

I tried for 30 minutes to jump onto that post somehow from every conceivable angle but aliter cannot do it. The worst part is, the post is highlighted in blue when using eagle vision so I'm pretty sure that I'm screwed.

Anyone have any advice?


11-21-2009, 08:07 PM
The way you do it, is that the the ledge where you climb up in the front. Hold R1+X and you will jump up their.

11-21-2009, 08:14 PM
Yah u have to get on the ledge on the balcony and run up the wall and jump left if u r on the right edge or to the right if you are on the left ledge dont feel bad it took me a while to figure this out to sometimes i double hit A and fell off http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

11-21-2009, 08:15 PM
Do you mean the ledge of the door? I tried that so many times. (On a 360 btw)

Or the railing of the balcony?

Anyone have a vid of this sequence? I couldn't' find one anywhere.

11-21-2009, 08:18 PM
If you are looking at the door there are two ledges one to your left and one to your right go on the ledge face the castle and run up as soon as you hit your peek of your run push your analog stick to the direction of the wood ledge and jump...

11-21-2009, 08:18 PM
Go on the balcony ledge then stand infront of the post and climb up. Simple.

11-21-2009, 08:23 PM
Oh if its for 360, im not exactly sure on the keys.

But click the Button Equivalent to the R1 Button, the one that gets you ready to sprint, or the one when combined with A that allows you to jump on items, and then click them on the front ledge.

11-21-2009, 11:45 PM
Thanks guys. After another 20 minutes I got it... so weird. The rest of the game has been a breeze except for that part!

11-22-2009, 08:55 AM
im stuck on the same bit (PS3), been trying for an hour, just cannot get up lol

11-22-2009, 09:01 AM
Sit on the rail, holt RT and tap A. Tada!