View Full Version : HELP!!!! select map button not working??

12-19-2008, 08:56 PM
Hey there, I have just started playing this, finding it an interesting game.
I have just beat the hunter in the Queens tower and cleansed it, but now my map button wont work and it seems like I cant get down off the tower. I just keep going down then back up again?
Is this a know bug or is there just something simple I am missing???
please any help would be really appreciated!

12-20-2008, 03:04 PM
come on guys!!! surely someone must have an answer?
I am about to call the UBI number and blast them haha http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

12-20-2008, 03:11 PM
...and its still not working!!!!!!!!!!!!!

12-20-2008, 06:36 PM

Actually I am looking for the answer for Worrior fight, but I have your answer as I had same problem at the start.

Here what you can do is two things - take the xbox game dvd out and put it back it will rerun the game as you see that "the console needs to be updated to play this game" message in start.

second thing is that map button will not in function untill you not reach to Temple with elika and atleast fight once with Elika's father. After that fight you have to come out and from there your Map Button start functioning as the game actually start from there.

Let me know if this helps.

Have good luck

12-21-2008, 04:31 PM
hey mate thanks for your ideas but sorry not really much help...
Firstly I have a PS3 not Xbox360 (thank fcuk) and secondly I am WAAAAAAAAAY further into the game than the 1st encounter with Elikas father.. I have just beaten the warrior and cleansed the princesses tower. The bug happened straight after the fertile ground was cleansed. Now no map at all!!!
I press the green triangle (so Elika can cast her spell to show me the way...) then the blurb at top of screen says 'press select to mark a direction' (or whatever..) so I try to do this but nada.
I have played on hoping it would sort itself out but it hasnt!! Even swapped controller thinking the select button was faulty no joy!
I am over this game because of this simple but HUGE bug.

12-22-2008, 05:52 PM
you're still at the fertile ground right? How about you try teleporting to one of the other fertile lands and try to select map from there? I remembered i can't select the map once, and i think i did this to solve the problem.

Have you gotten enought light seed for the second power? If you have, just teleport to the temple and get it and prepare yourself.

12-25-2008, 02:17 PM
sweet thanks bro I will try this

12-27-2008, 08:34 AM
Originally posted by dmonbloodbane:
sweet thanks bro I will try this

01-04-2009, 11:19 PM
small problem:
I must be on the map screen to teleport?
so this wont work..

01-05-2009, 08:38 PM
bump http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

01-06-2009, 03:42 PM
come on has nobody else found this bug yet????????????????????????????
I am bout to smash my copy of prince of persia up and wee on it.

01-06-2009, 07:38 PM
Sorry dude, but it could be a corrupted file
so you either have to start form a different save point form BEFORE teh bug happenend,
or start again,
but why dont you just climb down the tower, you dont NEED the map, just grind down, and move on,
if that dont work then start again

And try not to double post buddy

01-07-2009, 02:45 PM
Believe it or not I have hit the same bug. I am at the exact same spot you are just finished the queens tower and am near the end of the game. Just have to collect another 80 light seeds to reach the 540 to unlock my final power the blue plates. I can no longer get into the map selection screen however and am now stuck trying to find my way around myself. Any suggestions would be much appreciated!

01-07-2009, 03:40 PM
Find your way back to the temple and then go from their,
But if you REALLY WANT to have the compass and map, then try starting again, or load a save point from before the bug accured and delete the save file with the bug on it

01-08-2009, 09:42 AM
I tried what you suggested godsmack, found my way back to the temple on my own. At first still no change. The select button did not respond, so no map selection screen. I saved again at the temple, powered down the system and reloaded the save, and it worked! Thanks for the help, seems like it would be a pretty noticeable bug hopefully a patch can fix this issue.

01-10-2009, 04:31 PM
the same this happened to me, i just saved it and restarted, and the problem went away =]