View Full Version : Leo Bodnar board potentiometer problem

07-05-2008, 12:58 PM
Hi chaps,

I've converted a Saitek X35T to USB using Leo's BU board.

I have one problem I can't figure out:

I can't get IL2 in-game to give me more than 33-75% power.

I can calibrate the throttle in windows and it it appears to work fine, but not in-game. It's like the game picks up limited range from the pot or something.

I've tried two different pots on the throttle position now, but the behaviour is the same.

Other pots connected to the controller board seem to work ok - I use those for trims (maybe they give limited range as well but I don't know it?).

Has anyone seen anything like this? I can't use my throttle, and I'm hurting!



07-05-2008, 02:07 PM
rather strange symptoms, i agree.
presume it is wired correctly and no 'whiskers' of wire shorting out anywhere?

when you say power max is 33-75% is it consitantly reaching the same percentage during a flight and changing to a different max on a different flight- particularly after a reboot- or does its max vary each time you open the throttle? also does it return to 0% every time?
the later behaviour would indicate slippage between your throttle lever and the pot shaft or the pot itself moving on rotation. this would be my first thing to check.

if this isn't the cause here's a couple of things to try which may narrow down the cause.

first off is this the only controller connected to your pc?

2) have you tried connecting the throttle pot to another input on the bu0836? i presume you have a spare or two? (disconnect usb cable before doing this) hopefully this will eliminate the remote chance of a duff input on the board

3) create a new pilot (i assume you haven't changed the default ini?) and reassign axes as appropriate. retest. any change?

4) still not right? try assigning one of your trim pots as throttle and test ingame. does this give 0_100% response?

these tests should at least point us in the right direction.
one other thing- have you tried resetting to default in the windows calibration screen for the bu0836?

btw you can check elev trim operation ingame with a spitfire- gauge is in lower left of instrument panel (pit on of course)

good luck

07-05-2008, 03:40 PM
Fixed it!

Thanks Bolox.

I disconnected and deleted the BU in Windows, put the original pot back in the casing and then rediscovered the board in Windows.

I ran the throttle pot on a different connector on the BU board as well.

Calibrated in Windows, went into the game and tried the different pots in the Controls screen - all give smooth 0-100% when configured as power.



07-05-2008, 05:47 PM
Oh bother, the problem is back after I closed up the throttle housing. Back to 33-76% throttle.

I also have a short on one button as well - I'll break it open again tomorrow.

Thanks for the top tips for troubleshooting - I'll let you know how it goes.


07-05-2008, 06:16 PM
umm.. so it works fine with case open then goes screwy when closing case?
sounds like a wire (or 3) is being bent on closing either shorting something or pressing on a 'dry joint' try wiggling wires with case open to see if you can replicate with case open.

should be around tomorrow so we'll try again then