View Full Version : achievements

03-25-2011, 02:31 AM
where can i check the achievements that i already got on ACB? i receive the notifications on the game, but then i can't find where they are listed. i had the same problem on AC2, i played it for one year and i never found where my achievements were listed. i have both 1st and 2nd AC on retail and steam versions, and now the ACB on steam. steam is not listing any AC achievements, i can't understand why, and even on game menu, on uplay, or assassinsnetwork are not possible to find it. what am i doing wrong? how can i locate my achievements???

03-25-2011, 06:36 AM
Enter any Guild - there you can see blackboard, clicking on it will show you yourachievments.

03-25-2011, 08:54 AM
on PC the only thing shown on those guild blackboards are the challenges, i checked all blackboards and couldn't get access to the achievements.

i found here the list http://www.xbox360achievements...erhood/achievements/ (http://www.xbox360achievements.org/game/assassins-creed-brotherhood/achievements/) but as i'm unable to access my achievements, i have no idea about which ones i got and the ones i'm missing. maybe there's something wrong with my account on uplay, or something. this is very weird.

03-25-2011, 09:01 AM
On PC Achievements can be seen in the menu.

Go to Menu -> Options -> Statistics -> Achievements, at least that's who i recall at, at work atm so can't double check...

But Achievements are definitly there!

03-25-2011, 10:04 AM
oh, i missed that http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif thanx. i'll try to synchronize the achievements with giantbomb.com now http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

btw... i tried the same tip for AC2 i couldn't find it on stats there. do you know where it is on AC2?

03-25-2011, 11:20 AM
AC2 doesn't have any achievement's on PC, except for the uPlay ones.

03-26-2011, 12:57 PM
I'm not getting a 'statistics' option in the options menu. All I have are: 'Spoken Language', 'Subtitles Display', 'Subtitle Language', Customize Controls', 'Graphics'. Any ideas why that might be? I've got the Steam version.

EDIT: nevermind, I worked it out that I needed to load up a single player save to get to it.