View Full Version : MASSIVE error in Black Edition

03-15-2010, 06:52 PM
This will contain SPOILERS for those that haven't finished the game. Fair warning.

Ok, I'm at the end of the game, and am about to to assassinate Borgia. Make it all the way across the chapel, under the ceiling, lock on, make sure I have the hidden blade(s) equipped, jump...and he disappears. Poof, gone, as if he was a hologram. He's gone, the guards that were standing along the walls are gone, the priests and cardinals are standing there dumb as posts staring into space, not reacting at all that an ASSASSIN just fell from the sky as it were, and the cute little crosshairs are still on the map.

I've jumped NEXT to him and then back onto him, killing him just fine...but then I'm SEEN, and so get desynchro'ed. I've quit to the menu and tried again, I've quite the game and tried again...and keep getting the same error. So, what to do...any tips, anyone?

03-15-2010, 07:03 PM
Try shooting him with your pistol, it works just as well as stabbing him. If problems persist then try over at the Tech Help Forum. (http://forums.ubi.com/eve/forums/a/frm/f/4721051016)