PDA

View Full Version : Why does it take so long for game to load?



Hawgdog
12-16-2005, 03:11 PM
jeez, I have bigger games that load up quicker

SeaNorris
12-16-2005, 03:13 PM
Because it is loading up P-51 crud and making the U2VS uber.

Wilburnator
12-16-2005, 04:03 PM
It doesn't take long at all for me. BF 2 takes 3 or 4 times longer, for example, on my rig.

T_O_A_D
12-16-2005, 04:10 PM
Because your machine is a dog http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif

Dunkelgrun
12-16-2005, 04:12 PM
Because your rig is old and knackered?
Before I upgraded from an Athlon 2.0 to a new mobo and Athlon XP 3.8 it would take three or four minutes to load, always getting stuck on 70%.
Now, ten seconds loadup is when it's going slow!
Expensive way of curing the problem though http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif.

Cheers!

FoolTrottel
12-16-2005, 04:15 PM
It's just because yer impatient...

Hawgdog
12-16-2005, 05:15 PM
fooltrottel is probably correct, just seems longer to load than several other 'things'on my PC

yes, my system is a dog.
My 800fsb Northwood 3.0 is currently singing along at 830fsb and 3.25 and barely starts.
the 2 gigs of Geil 4000 can barely handle the 2,2,2,2,5 without whining
the ATI 9800 XT is a pig
the baracuda sata drive is lame
the abit IC7 is cardboard
and the fans are so loud I can hear them over the antec headphones..thanks, I'll go out tomorrow and buy a new rig http://forums.ubi.com/images/smilies/51.gif

III-JG27_DV8
12-16-2005, 05:23 PM
Hawgdog,
Might want to ...
1) Check the hard disk for errors (fix'em if there are any)
2) Defragment the hard disk (if you run multiple drives, one for games/stuff, other for WinXP/2K/9x, then I'd recommend you defrag all of them).
3) If you have virus software, you might want to add just the IL2 installation directory (make sure subdirectories are not scanned) to the Exclusion list (exclusion referring to not being scanned).
4) Shut down any services or TSR's (lol, long time since I've used that) that are not necessary while running IL2.
5) Quit Installing/Uninstalling software, this does impact - not only your OS boot time - but application load times, esp when applications are reading 2,3+ gb files at a time.

Good luck! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Monty_Thrud
12-16-2005, 06:18 PM
Quality takes time...

hobnail
12-16-2005, 06:46 PM
counter-intuitively overclocking sometimes leads to slowdowns especially with HDD access.

Tully__
12-16-2005, 07:33 PM
Entire game core is encrypted. Must un-encrypt before loading....

willyvic
12-16-2005, 08:45 PM
Originally posted by Hawgdog:
jeez, I have bigger games that load up quicker

Hawgdog,
Used to have same issue. Found out it was my Mcafee (sp?) virus protection and the original executable IL2 file. Disabled the virus protection. Got another exe file (nudge, nudge, wink, wink) Load times dropped dramatically.

Hawgdog
12-16-2005, 10:17 PM
Originally posted by III-JG27_DV8:
Hawgdog,
Might want to ...
1) Check the hard disk for errors (fix'em if there are any)
2) Defragment the hard disk (if you run multiple drives, one for games/stuff, other for WinXP/2K/9x, then I'd recommend you defrag all of them).
3) If you have virus software, you might want to add just the IL2 installation directory (make sure subdirectories are not scanned) to the Exclusion list (exclusion referring to not being scanned).
4) Shut down any services or TSR's (lol, long time since I've used that) that are not necessary while running IL2.
5) Quit Installing/Uninstalling software, this does impact - not only your OS boot time - but application load times, esp when applications are reading 2,3+ gb files at a time.

Good luck! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Ah, never thought, I bet its the Kaspersky AV app.
I defrag daily, use CC cleaner prior. I bet its the kaspersky, either the hacker side or the AV side, I've have problems with this software already.

~S~

Hawgdog
12-16-2005, 10:18 PM
Originally posted by Tully__:
Entire game core is encrypted. Must un-encrypt before loading....
ah, which fits right into my AV trying to make sure its not unloading some knarly spork.exe file http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

VW-IceFire
12-16-2005, 10:58 PM
I'm impressed how quickly this game loads for me....

Even tho my system is somewhat buggered up now...its still very fast. I should time it sometime.

SithSpeeder
12-16-2005, 11:21 PM
Hawg--

I'm with you, bro. I'll enter co-ops and dogfight rooms at the same time as the rest of my squad and I'll still be at like 40% when they are talking about the brief, loadouts, the planes they've chosen, etc. It seems like by the time I get in to a co-op, the only spot left is the bomber gunner on tail end charlie. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

However, my system is coming up on 4 years old, so that may be a major part of it.

* _54th_Speeder *

Professor1942
12-16-2005, 11:54 PM
I have two systems: a P4 Northwood 3 Ghz and an AMD64 3000+; both benchmark about the same, but for IL2 (and other games) the AMD system loads way, way faster.

I suggest scrapping the Intel...

WTE_Ibis
12-17-2005, 01:30 AM
Originally posted by Hawgdog:
fooltrottel is probably correct, just seems longer to load than several other 'things'on my PC

yes, my system is a dog.
My 800fsb Northwood 3.0 is currently singing along at 830fsb and 3.25 and barely starts.
the 2 gigs of Geil 4000 can barely handle the 2,2,2,2,5 without whining
the ATI 9800 XT is a pig
the baracuda sata drive is lame
the abit IC7 is cardboard
and the fans are so loud I can hear them over the antec headphones..thanks, I'll go out tomorrow and buy a new rig http://forums.ubi.com/images/smilies/51.gif
*************************************************

Yep that's your problem.
http://forums.ubi.com/images/smilies/88.gif http://forums.ubi.com/images/smilies/88.gif

.

Pig_Mac
12-17-2005, 02:38 AM
About the anti-virus, The kaperski is the most resource stealing anti-virus i've ever tried (almost worse then having virus!).

I used it to clean up my moms computer when i were on a visit, and she had problems. I left it on in the default settings and the computer (that is ****, since it's made out of tossed away things from my old comps), were hardly able to launch firefox in under a minute and with stutters.

So keep that one away from gaming computers http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

tjaika1910
12-17-2005, 03:37 AM
First of all: what is a long time here?

10 s, or several minutes?

I have ca 10 s startup time, which I consider fast. Starting up a finnish mission could take additional 30-40 s and maybe 10s in a rerun (cached)

I have 1 gigabyte memory (dual channel- 400) and a barton 2500+ (oc)

Maybe 2 giga would decrease the difference between a first a cached run.

I your times is longer with much better hardware (I have a ide disk too) something else is the problem. Check out the prossesses running.

Xiolablu3
12-17-2005, 03:48 AM
Thats strange, I never think of the game taking a long time to load?


I wsa going to suggest lack of ram but I see you have plenty.

Your system has nearly double the ram mine has and a better video card.

Maybe a reformat and reinstall is in order? Was the HD pretty full when you installed FB/PF? It may be fragmented on the drive, but still this shouldnt make that much difference??!?

Tully__
12-17-2005, 04:09 AM
Primary factors in load time are not limited to CPU performance. More critical are HDD read times for sustained reads (large files) and FSB speed. When I moved from a 133MHz FSB to a 333MHz, load time dropped about 25-30% even with everything else almost the same.

Kuna15
12-17-2005, 04:22 AM
Apart from hardware upgrades I find antivirus programs to be the most problematic in this regard.
When I disable my antivirus load time is around 10s or less, with antivirus it is around 30s maybe more.

Hawgdog
12-17-2005, 06:41 AM
I just timed it. About 50-52 seconds from when the splash screen first shows to when the menu is available.
I went in and told kaspersky to ignore completely IL2FB.exe for real time, but scan 'on demand'.
What happens at 20%? Seems to hang there for 30ish seconds.
Did a registry sweep etc, spent an hour yesterday double checking everything. Still loads about the same.
Wasn't there some software that moved programs around the disc to speed things up?
If I'm online, once the program loads, it takes just a couple of seconds to DL whatever map and get into game.


EDIT: HA! When I added the program to teh evil Kaspersky I forgot to include subfolders, or subparent somethings, went from about a minute to 6-8 seconds!

Thanks everyone for the valuable insights/ideas.

regards, merry chrismas

domenlovrec
12-17-2005, 07:04 AM
Hawgdog, i have same problems. It just hangs at 20% and 70%. I also have kaspersky, but i don't know how did you do that. Can you please show me the steps?

Hawgdog
12-17-2005, 07:19 AM
yeah brudda,

double click tray icon

click settings

click threats and exclusions

click "add"

search your pc to find the program, mine was
C:\Program Files\Ubi Soft\IL-2 Sturmovik Forgotten Battles\
uncheck "on-demand"
uncheck "real-time email protection"
The only one checked is "real-time"
stop there, cick ok

edit: make sure the entire folder NOT just the .exe file is the target
regards

Professor1942
12-18-2005, 01:22 AM
Originally posted by Tully__:
Primary factors in load time are not limited to CPU performance. More critical are HDD read times for sustained reads (large files) and FSB speed. When I moved from a 133MHz FSB to a 333MHz, load time dropped about 25-30% even with everything else almost the same.

The problem has nothing to do with FSB or HDD speed; it just sits there at 20% doing nothing for a while. It does this on my P4 system but not the AMD64.

MC202zipper
12-18-2005, 01:22 AM
Originally posted by Xallo_72:
About the anti-virus, The kaperski is the most resource stealing anti-virus i've ever tried (almost worse then having virus!).



So try Norton 2004 or 2005, you will definitely see your PC crawl to a slideshow http://forums.ubi.com/images/smilies/34.gif

If you aren't online kill everithing you don't need with FS Autostart (download from AIRWARFARE page).
Or try AVGfree, I sometimes forget it on when I play a quick one and I barely notice any difference...if there is one...that AVG is outstanding, works OK and is very light...

About long loading times: a good hard disk maintenance & **** cleaning is essential, but two disks in RAID 0 are even better...

S!
MC202zipper

Hawgdog
12-18-2005, 06:58 AM
Yes, Norton will absolutely destroy any speed your PC had.
Then the fun begins, try and uninstall it! It makes AOL looks noninvasive!

T_O_A_D
12-18-2005, 01:46 PM
http://forums.ubi.com/images/smilies/1072.gif Sorry Dawg I thought you was just joking around.

Well its good you have made progress.