View Full Version : Memory Block 4 - 4th Assassination problems.

11-17-2007, 10:16 AM
I've reached the 4th assassination, with your choices being in Acre, Damascus or Jerusalem, but I had already picked up most of the view points, so when I go to speak with the Assassin at the Bureau, he gives me a tip, and then I receive no marker on my map, what-so-ever.

So, I've roamed each city for countless hours, for two days, and I haven't found anything for investigation.

If someone could possibly provide assistance, that'd be great. If not, I'll start over at Memory Block 3, and approach the view points -after- speaking with the Bureau's attendant.

11-17-2007, 10:25 AM
You have to "FIND" a viewpoint in the area that the guy at the Bureau directs you to. He'll tell you to check out the east, west, or somepart of the city. Do that and find a viewpoint. Then, the rest will open up.

11-17-2007, 10:26 AM
You have to crawl up to a high place you havnt been and then synchronize(sp?) after that markers will pop up on your map

11-17-2007, 10:26 AM
Oh yeah?

Okay, thanks.

Too bad I had a friend over, and didn't hear where they directed me to in any of the three cities.


11-17-2007, 10:31 AM
Problem solved - Tower found.

Thanks for the assistance.

Lock thread?

12-16-2007, 10:44 PM
where is the tower located, i have the same problem.

12-17-2007, 07:05 AM
that's not work i have take all veiw points an checked all citys from the top to dowm and from side to other side and from east to west north to south corner upper right to corner donwer right and left corner down to left corner upp its not work!!!!!!!!!!!!!! http://forums.ubi.com/images/smilies/784.gif <span class="ev_code_BLUE">damn!</span> <pre class="ip-ubbcode-code-pre"> </pre>
raitlA ITS NOT WORK!!!!!!! http://forums.ubi.com/groupee_common/emoticons/icon_mad.gif http://forums.ubi.com/images/smilies/1241.gif

12-18-2007, 01:35 PM
i have been on every damn tower there is....and still no icon has appear to start me off...plss can someone help me?