PDA

View Full Version : Dear Vlad The Impaler, where are you?



jeffdeathleach
11-29-2011, 07:51 PM
What a nightmare... I've got my 100% synch on everything and then I remember because I pre-ordered the Collector's Edition I should have some extra content.

Lo and behold my Vlad The Impaler mission is missing, even if I start up Sequence 3 Memory 10.

Boo AND hiss.
Did anyone else have this problem?

LightRey
11-30-2011, 12:47 AM
I would assume you got a code with the game to unlock it, cause if you didn't that's why you can't find it and if you did it's either a glitch or you're not looking well enough.

LordWolv
11-30-2011, 01:41 AM
Follow these steps to check:

1. In your game case, there should be a sheet of paper with a code on it. If you've already redeemed that code, move on to step 2. Go to the main menu of ACR, click extras, then it will say something like 'Enter Code' or 'Extra Content'. Click here and enter your code exactly, it should then be redeemed.

2. The mission will be under a 'Templar Den' icon. Basically a small Templar symbol (A cross). Go to this and walk through the door.

3. If you've searched over the whole map and convinced you havn't missed anything, AND redeemed the code properly, contact Ubisoft Support.

Hope I helped. http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

Krayus Korianis
11-30-2011, 02:53 AM
Vlad the Impaler's Tomb mission starts off in Sofia's book shop... In sequence 3 you are allowed to activate the tomb.

Go to Sofia's shop, go forward and to the left there should be a glowing book. Press B/O next to it to activate the tomb itself.

Go to the sewer tunnel entrance in front of Sofia's shop, go to Arcadius. Then go to the tomb entrance as it's right next to the Arcadius sewer tunnel.

EscoBlades
11-30-2011, 02:54 AM
If you correctly redeemed the code to unlock this location, then go to Sofia's Bookshop. There you'll see a shimmering book. Interact with it and ezio will "learn" the location of The Impaler's Tomb (it will appear on your map)

The location is in the cemetery south of the Constantine District, and is shown on the map by a Hidden tomb marker.

Have fun.

Krayus Korianis
11-30-2011, 02:58 AM
Ah ha! I beat you EscoBlades!

EscoBlades
11-30-2011, 03:29 AM
Originally posted by Krayus_Korianis:
Ah ha! I beat you EscoBlades! http://forums.ubi.com/images/smilies/compsmash.gif http://forums.ubi.com/images/smilies/crackwhip.gif

M3GASUS
04-04-2012, 07:27 AM
Does anyone know of anything that might activate the book being in Sophia's shop? I have beaten the game and now realizing I should do that mission the book is not there. I have used the dlc code (multiplayer extras are there like the ottoman jester) I have tried going back to sequence 3, going to sequence 5, tried various little side missions, and then contacted ubi support only to be sent a email with a link to a page I have already seen. Is it that since her shop is now trashed it's not accessible anymore? Started a new game and played through it awhile but that area isn't accessible yet so don't know if it's worth continuing to bother with. Any help would be great.

freddie_1897
04-04-2012, 08:30 AM
read isaacs post

Daw_Knob
06-04-2012, 09:18 PM
I'm on sequence 6 and I've just had a location marker for the hidden tomb location come up at Sofia's book shop. I've collected the book, revealed the location of Vlad's tomb and entered it. The problem is that the mission didn't start. I haven't had any kind of cut scene/animation/start sequence. I can reach Vlad's tomb, but get no option to open it. Plus, as the game has saved when I entered the area, when I quit it just reloads at the start of the area.

The thing is from reading these forums, I shouldn't even have been able to access the tomb as I don't have the collectors edition.

Does anyone have any ideas or have I got to start the game again?

Cheers

Serrachio
06-04-2012, 10:02 PM
If you bought the Lost Archive DLC, you unlocked all the digital content that you didn't have with the game.

If you did, and the mission won't load up for you, it would be best that you send a support ticket to Ubisoft Support and make sure that it doesn't close.

Zombieland
06-15-2012, 12:42 AM
I may have a possible solution.

I was having the same problem described before. I bought the DLC, and after a tough time getting the correct patch to work and the DLC to recognize it, I was able to get it installed. I could see the unlocked multiplayer characters, but none of the singleplayer content.

After a long time spent trying to fix this, I reasoned that the problem must be on Ubisoft's end, and I switched to offline mode. Despite the warning about not being able to access extra content, everything appeared as it should.

Having to go offline to use the content that I paid for makes me wary of buying products from them in the future.