PDA

View Full Version : AC:B Crappy preformance



zippo100
04-01-2011, 05:53 PM
Hi, I have relatively low preformance considering the fact that my PC meets recommended requirements. I have a ASUS Geforce 9600GT 1GB DDR3 ram version. I am aware that it's far from top-of-the-line GPU compared to graphics cards nowadays, but meets recommended requirements nontheless.

As far as I understand assassins creed brotherhood is no particular upgrade in terms of graphics on the minimum grpahics or maximum graphics, so why do I get such crappy framerate at full HD resolution with everything turned to low (crappy is 15-20 FPS) when I got at least 25-30 FPS on assassins creed 2 everything turned to max except for Vsync. Please explain because another guy I talked to had like stable 60 frames per second with the resolution of 1280x720 and when I tried that I got max 30 frames per second, please advice or help

Razrback16
04-01-2011, 06:25 PM
What kind of CPU do you have and how much RAM? The video card is the most important thing with PC gaming, but the CPU and RAM are contributing factors as well.

zippo100
04-02-2011, 04:18 AM
I have 4 GB DDR2 RAM and a Q6700 quad core processor from intel at stock clock speed of 2.66 Ghz

Razrback16
04-02-2011, 08:53 AM
Ok, the weakest thing there is your vid card. You should look into upgrading -- the 9600 GT isn't a piece of crap by any means, but it is pretty dated. If you could even find yourself a 9800 GTX or an ATI 4870 for dirt cheap (I sold a pair of 4870s for $75 each like 2 years ago, so you could probably find them dirt cheap on craigslist or ebay).

Lord_Ethcaz
04-02-2011, 08:57 AM
I'm not too familiar with that videocard's benchmark, but if it meets the recommended settings, you should be able to play fine with it.

Try only turning off the settings that require the most power, Vsync you already had turned off, but AA, multisampling and, someone said, shadows, can also be turned down without causing the game to look ugly http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

chris5896
04-02-2011, 09:08 AM
I had an issue with the performance, too. I had about 1 - 2 fps even on the lowest resolution and everything turned down.
This helped me: open AC:B, then go to Task-Manager, go to processes, right-click on AC:B and then select the button right under priority (I don't know it's english name, but if you translate it literally it's affiliation). Then remove the tick from two of the four boxes, so the game only uses two of your four CPUs.
As it seems AC:B has some great issues with quadcores. After I did this, the game now runs totally without any laggs.

mmdore
04-02-2011, 09:40 AM
what bout ppl with 2 cores =(

Lord_Ethcaz
04-02-2011, 09:43 AM
Originally posted by mmdore:
what bout ppl with 2 cores =(

No issues.

ace3001
04-02-2011, 10:01 AM
Originally posted by faidh:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by mmdore:
what bout ppl with 2 cores =(

No issues. </div></BLOCKQUOTE>And as far as I can say, no issues for those with 2 cores + 2 logical HT cores either.

zippo100
04-02-2011, 07:10 PM
Yea RazrBack16, you're right http://forums.ubi.com/images/smilies/16x16_smiley-happy.gif guess I didn't now just how eak the 9600 was when I first bought it ( back then I thought the higher the number, the better the card was) I guess I'll just buy 2 of those you mentioned thank you for reply

jelf22
04-02-2011, 08:07 PM
Try going to nvidia's website and download the latest driver if you haven't already.
Sometimes this may help a lot especially if you haven't updated your driver for a while.

Though this may also have something to do with 9600's weak performance under high resolution.
Try lowering the resolution and see if that helps.

Silence911
04-03-2011, 06:32 AM
I am running the game on a pentium d processor(2 GHz),my gpu is geforce 9400 GS(1 gb) on a winxp sp2,ram is 1 gb and yet i play the game on high settings (not the highest) and it runs smooth.Why!Because i increased my virtual memory paging file size to 4 gb..prior to my doing so the game lagged like hell..but now it runs faster.AC:B does not require high end gpu(it even supports geforce 8 and runs on dx9.0c)..So dont waste your money and use your limited resources wisely..and always remember that unless you own intel i7 you dont need ram more than 4 gb..

mmdore
04-03-2011, 10:56 PM
I have same issue low fps but managed to get better improvement by formatting my pc, havent installed any windows update lol, its a bug that happens to some people.

bveUSbve
04-04-2011, 07:29 AM
First I played with AA configured (and overriding the application) in the Nvidia-Control-Panel. FPS were quite good -- but light-sources were visible through walls.

The solution to this problem is to set AA-Mode to be defined by the application.

But now the FPS weren't good any more. Next I installed Nvidia's latest (beta-)graphics-driver: "270.51".

With this the performance is okay once again.

(Disabling 2 of my CPU's cores didn't improve anything; it rather seemed to make things worse.)