PDA

View Full Version : IL2 46 is running rough - any ideas on how to smooth it out?



sledgehammer2
12-27-2006, 07:23 PM
I saw the thread on Nvidia but I have an ATI X800 series card, a gig of Ram, and I really have this thing running choppy. I use Water=1 and perfect landscape. I went into the Conf file after loading up 46 and disabled the 3d gunners. That helped some but this thing is not running smooth. 4.04 never did either and I thought a clean install would help, but it hasn't.

Do I need to search for some SecuRom files and get rid of those? I use 1024-768 32 bit, and my ATI settings are no Anti Aliasing, not Anisotropic Filtering, Vsync off, 4x and 2x. I hope I have given enough info for someone to help me here. I would appreciate it - it's pretty frustrating. Also, I use Track IR 3 Pro.

Sledgehammer2<div class="ev_tpc_signature">

A war correspondent in 1944...
"For sheer brutality and fatigue, Peleliu surpasses anything yet seen in the Pacific..."

Stargazer_RobW
12-28-2006, 02:50 AM
Sorry Sledgehammer, I don't have a clue about fixing framerates, but I'm having a slightly similar issue and thought it best not to start a whole new thread for a related issue...

If however, I skew your thread well away from what you were asking, feel free to put a Brick through my living room window with note strapped to it telling me to 'shove off'.

I get a nice smooth framerate almost all the time but as soon as I pan the camera or fly towards the coastal town in the American Fighter Pilot career (the one after pearl harbour) the framerate drops really low.

I can only imagine it's all the trees doing it since Pearl Harbour and Solomensk both give me nice smooth framerates at low altitude.

I'm reluctant to drop quality settings since my PC should be able to handle it. Sure, it isn;t state fo the art but it's no slouch either. Athlon 3400+ 64bit, 1gb Ram, PCI-e Geforce 6800Xt 512mb, Nforce4 mainboard.

I've had a bit of a browse around here and found several tips on improving performance and wot-not but so far everything remains the same. Also, my ground detail wont go up to perfect although my wife's old old OLD PC with it's bronze age FX5700 AGP card allows Perfect landscape.

I'll shut up now before I take the focus away from sledge hammers query even further.

Rob.

VFA-195 Snacky
12-28-2006, 03:28 AM
I think it's the new trees.

I can run 404m maxed out in perfect, but in 4.071m I have to set my landscape to excellent. It's playable on perfect, but bogs down when the new trees are around.

There has to be a way to use perfect landscape and just set the trees lower or the way they were in 4.04m<div class="ev_tpc_signature">

http://us.st11.yimg.com/us.st.yimg.com/I/airplanepictures_1918_16003860

sledgehammer2
12-28-2006, 04:15 AM
I hadn't thouht about the trees. I didn't know we had new ones. If I dropped my landscape to excellent could I still have Water=1 looking like it does now, or would it downgrade that?

If they have bumped up the quality of graphics I am not complaining mind you, but I really don't want to have to back the settings down if I can help it.

I know some think it could be SecureRom, but my install was trouble free.<div class="ev_tpc_signature">

A war correspondent in 1944...
"For sheer brutality and fatigue, Peleliu surpasses anything yet seen in the Pacific..."

RCAF_Irish_403
12-28-2006, 04:32 AM
Here's the conf.ini guide over at AirWarfare. There are a few things you can do with this file 6that can help FPS-just make a copy of the old conf file (http://www.airwarfare.com/guides/config_guide.htm)

This is a guide that explains how to tweak your graphics card for optimum game play (http://www.airwarfare.com/tech/graphicsil2.htm)

Link to IL2 optimization guide (http://www.airwarfare.com/guides/il2optimisation_guide.htm)


http://forums.ubi.com/images/smilies/typing.gif<div class="ev_tpc_signature">

Originally posted by marc_hawkins:
Don't be too proud of this technological terror you've constructed. A 108:0 kill ratio is insignificant next to the power of the Force

http://www.fas.org/main/home.jsp

Stargazer_RobW
12-28-2006, 04:53 AM
Should I be running in this in Open GL?

I always had the impression that DirectX was the way to go but Airwarfare says IL2 was built with OpenGL in mind.

Will I see an improvemnt in framerate or a drop in quality or vice versa?

Me is confused... Does not compute!

Rob.

Feathered_IV
12-28-2006, 05:33 AM
Open GL definitely http://forums.ubi.com/images/smilies/25.gif

Forest=3 is the nice trees that move in the breeze. They have a noticable performance hit.

Maybe try putting your graphics setings down to their lowest, then fly around for a bit. Exit and restart. Then try improving the graphics levels incrementally, testing as you go to find out what works best for your setup.<div class="ev_tpc_signature">

***********************************************

http://server2.uploadit.org/files/Feathered-sigpic.jpg

"Intelligent, normally observant and answered all questions freely. He was arrogant and proud to be a pilot. Fellow prisoners in hospital consider him mentally unstable."

PFflyer
12-28-2006, 06:13 AM
What cpu are you running? And what resolution?

You should have a cpu that runs at least over 2000mhz if an AMD, and over 3000mhz if intel, for best results.

Whatever version of atI card you have, I hope it is one with 16 pixel pipelines or you missed the boat. You MAY be able to flash it's firmware up to a version that has more performance if you google: "x8xx firmware", you will see all kinds of guys who upgraded them.

I hope you are not trying to run more than 1200x1600 resolution, you probably will have to run a bit less than this for best results.

Set water=0, it will still look great on perfect mode.
Run Catalyst Control Center with default settings and let the application decide what to do with it.
Make sure in your bios that your AGP aperature is opened as wide as it will go. JUST TRY IT.
Yes 3d gunners should be set to "0".



IF you are in the above parameters and it still will not run, try borrowing a stick of ram and trying another 256-512mb.

Ruy Horta
12-28-2006, 12:39 PM
last time I hinted anything like that it cost me 2 weeks of forum time. Nice weeks they were too!<div class="ev_tpc_signature">

http://forums.ubi.com/images/smilies/59.gif
Ruy Horta

http://img212.imageshack.us/img212/7748/signaturecommunismih6.png

BaronUnderpants
12-28-2006, 12:46 PM
I found after some testing with BlackDeath that turning your screen res. from 1024X768 up a noch to 1152X864 could cause u to loose as much as 10 fps.

Maby doesnt sound much but going from 47 fps avg. to 37 fps avg. is much to me, so ill stick with 1024X768.

47 fps avg. in BlackDeath mind u, did a QMB with maximum planes ( 32 jets in all ) with icons on crimean map. Fair amount of AAA from boats...and still got 74 fps avg. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

steve_v
12-28-2006, 03:56 PM
sledgehammer2, let me suggest the following. You start a thread in Community Help forum and include the following

dxdiag
opengl portion of your conf
your ati control panel setting along with the FRAPS log from Black Death run form 0:05 to 2:30.

You're really not providing any factual information in this thread. With the above information, you'll at least get some educated guesses. Also, at water=1 my FPS takes a 15% hit.<div class="ev_tpc_signature">

<center>http://img.photobucket.com/albums/v645/The_Presz/natlchamp_logo.jpg

When you get to Magnum-PC.com (https://magnum-pc.com/Search/External/) tell 'em HawgDog sent you.

Oleg Maddox ~ "Enjoy please Il-2 1946 DVD now"

sledgehammer2
12-28-2006, 05:50 PM
I will post a thread at Community Help as you suggest Steve. Also, my res is already at 1024x768 32 bit. My water is set at 1, what is yours at?<div class="ev_tpc_signature">

A war correspondent in 1944...
"For sheer brutality and fatigue, Peleliu surpasses anything yet seen in the Pacific..."

steve_v
12-28-2006, 06:09 PM
I just got 46 today and posted my FRAPS log and settings in tech. You'll see the thread. I'll be looking for yours.<div class="ev_tpc_signature">

<center>http://img.photobucket.com/albums/v645/The_Presz/natlchamp_logo.jpg

When you get to Magnum-PC.com (https://magnum-pc.com/Search/External/) tell 'em HawgDog sent you.

Oleg Maddox ~ "Enjoy please Il-2 1946 DVD now"