View Full Version : problem with map objectives

12-19-2007, 03:38 PM
I've played this game for quite a few hours and am having difficulty clearing out Jerusalem. At first I just wandered the streets looking for objectives (didn't understand the map) and after a while I learned how to select the objectives (pickpocket, eavesdrop, interrogate, rescue, viewpoint etc) for easier navigation - problem is, when I hit the map button it shows me only 2 of 6 investigations are done yet no more show up on my screen. On the map screen it says to climb viewpoints to find the objectives, but I've already climbed them all, and climbing more doesn't make anything else appear.

I've wandered around a bit but can't seem to find anything.


(playing on xbox 360 & love the game!)

12-19-2007, 03:50 PM
You probably just missed something silly. We can't really help you until you tell us what memory block you are on.

12-19-2007, 04:09 PM
Memory block 4

12-19-2007, 04:11 PM
I've tried everything I can think of, even started another game under another xbox profile.

One thing I didn't do was pickpocket the USB device from the Dr while out of the animus... I got the password but didn't see how to ppocket.

12-19-2007, 06:02 PM
under "Select Destination" screen, only Jerusalem & Damascus have the ][ target symbol...

12-19-2007, 06:15 PM
Domascus shows 0 of 6 investigations complete
I went to Acre, hit the map button & in the upper-right corner under "status" it said talk to the bureau leader in Jerusalum & Damascus - I went to Damascus & the Bureau guy said "finished with your assignment?" No my guy said, "well, don't let me interfere with your business".

Argh!!! this is frustrating

12-19-2007, 06:18 PM
Have you tried going to a different district?

12-19-2007, 06:37 PM

The guy @ the Jerusalem Assasin's Bureau just said something about an execution - I seem to remember one of them saying I needed to stop something but it's been a few days.

I got so stuck I started another profile but I'm a lot farther on this one...

12-20-2007, 10:20 PM
all I had to do was go to the rich district.

thanks for all the wonderful help.