PDA

View Full Version : Newbee questions......



dgk196
06-05-2008, 08:24 PM
I have IL2 1946. Can anyone tell me which of the updates or patches are needed?

Dennis

Skycat_2
06-05-2008, 08:48 PM
See my updating link in sig.

The DVD originally shipped as v4.07m which means you'll need the 4.08m patch. I think the download version is automatically updated.

There is also an official 'beta' version of what will supposedly be the last patch, version 4.09. However, the beta patch was released right after the new year and there has been little news regarding the final version. The online community is split between using the beta and not using it.

dgk196
06-05-2008, 11:24 PM
Thank you very much. You saved me several headaches, I'm sure.

Dennis