View Full Version : There is a terrible BUG in story mode.....help me!!!!

01-03-2011, 09:10 PM
In the Thief's guild challange,
there's one condition called
"pickpocket for 250f"
I had already finished it but it displays:
<span class="ev_code_RED">255/250 pickpocked</span>
then the challange is not unlock!!!!
what the hell is that problem????
now I can't get the" La Volpe's Bite "
I hope the next update data can fix this problem

01-04-2011, 02:15 AM
I feel for you bro. I have not experienced that problem, but I'm a '100% kind of guy' and would hate that.

Maybe a patch. But to be frankly honest, I think not.

01-04-2011, 05:27 AM
I have the same bug, luckily I got maria's dagger and altair's sword especially but it's a bug that a lot of people got, me being one of them. I don't think there is really anything we can do though as far as I know. I always go in there hoping maybe they fixed it with a patch or maybe this time it'll show up but it's still not there and I beat those challenges long ago.