View Full Version : any luck with a PowerBook

10-01-2004, 08:04 AM

I've the PowerBook G4 "DVI" with a Radeon 7500 (32MB).

Will it run?
Can anyone test?
(The demo crashes after a few seconds)
(Ubi did not respond to my question)

Ciao, ALeX.

10-01-2004, 10:01 AM
I'v successfully run it on the 17" 1.3ghz Powerbook, but the voice syncing got out of wack a bit.

10-01-2004, 12:15 PM
Unfortunately laptop chipsets aren't officially supported. But, lucky for you this also seems to affect other systems with an ATI 7500. I've already made sure the fact that ATI 7500 chipsets are having issues has been passed on.

10-01-2004, 10:25 PM
Works on my 12" G4 - system 10.3.5, card is GeForce FX Go5200 64 MB.

All fine except there is about a 2 second delay in rendering navigation -- kinda slows you down. Also happens on my G5 desktop so is not a PB problem. Annoying. All other Myst game nav clicks worked without delay. Wonder if anyone at UBI tested on the Mac side, eh?

Also seeing audio/video mismatch in the QT movies.

10-02-2004, 04:24 PM
Posters elsewhere say that the navigation delay is deliberate & happens on PC side also. Go figure. Not a function of CPU or RAM or vidcard.

10-09-2004, 08:07 AM
Hi, just to let you know that graphics are not displayed correctly on my PB G4 667Mhz (ATI M7 graphic chipset).

If someone out there knows how to fix this problem: Let me know. Very sad not to be able to play the game.

10-09-2004, 03:14 PM
That's a Radeon 7x00 based chipset.

10-11-2004, 03:14 AM
I tried the demo on a 1GHz 12" powerbook G4 (NVidia FX5200 GO). Starts up fine, but as soon as the game menu is shown, everything slows down so much, it's not usable (mouse lags about 10 secs). In the options menu, it runs normal (when I manage to get there), and when I manage to start a game, the screen with the book is ok. When the game starts it's back to 10-sec lag again. Are there any settings that need to be tweeked?

10-11-2004, 03:43 PM
Whoa, no clue there fry-a-wire. Try turning off all graphical effects in the game and see where that gets you. Make sure you aren't running anything in the background?

10-12-2004, 04:54 AM
Thaks, I have played around with the controls, and it seems that the only thing causing the trouble was the depths-field option. Having that disabled everything seems to work quite well.
What exactly is that depth-field effect about? Am I missing out on somthing really spectacular?

10-12-2004, 11:12 AM
It makes the game work like a camera. It supports Depth of Field (DoF). Interesting effect in that cameras can't focus on everything at the same time. So the area your mouse is at is in focus and the rest of the screen blurrs out incremently.

Cool, but unnecessary for game play -- and even annoying to some people.

10-13-2004, 05:33 PM
To reply to the original post: yes, Myst 4 does work on my PowerBook G4 667 (DVI) with Radeon Mobility 7500 chipset... up to a point.

You have to make a change to one of the files and also put up with occasional dark rectangles of varying transparency which appear in some places. See this thread (http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=580100736&m=9951097522) for further details.

The problems seem to be affecting the desktop (i.e. non-Mobility) Radeon 7x00 chipsets too, so with luck a fix will be available soon which will correct the problems for PowerBook users too!