View Full Version : Friend of the family quest bugged

11-18-2009, 01:05 AM
The crate of paintings leonardo and maria want you to carry is not able to be picked up by the pickup object command. Instead you just keep "gentle pushing" imaginary people away. I've read of other people not even getting the box to display.

Dropping the quest hasn't helped. Restarting the console hasn't helped. I'm at a loss.

11-18-2009, 01:33 AM
Have you tried tapping the pick-up button instead of pushing it down? That worked for me no problem.

11-18-2009, 10:30 PM
This is definitely bugged on 360.

If you attempt to pick up the box by *holding* B, it just disappears. You can no longer pick it up and you're not physically carrying it as you are with a successful pickup.

At this point you still have the blue "begin" marker at Leonardo's house but no yellow "delivery" marker. If you walk back to your house anyway, you'll get a notice to press B to drop the crate, but there's no glowing quest indicator. At this point the game is hung since you can't undertake any other quests.

I worked around by quitting out of the game and jumping back in. This time at Leonardo's, I just tapped B to pick up the crate. When you do that Ezio bends over and physically carries the crate and the yellow quest marker appears. You can successfully walk back to your house and drop off the crate now.

11-19-2009, 01:56 AM
I don't think it's glitched. I at first thought I had to hold the button and it didn't work, but I then just tapped the button and it worked just fine. You most likely didn't discover this until your reset PetroRjak. http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

11-19-2009, 02:43 AM
This has nothing to do with the topic but OniLinkSword's sig and avatar raise a good question.

Why the hell does Sam Fisher wear those stupid goggles with the 3 green glowing lights on his head? Sam is lucky his enemies are half blind because by all rights he should be riddled with bullets by now