View Full Version : How to user parachute? - X360

11-24-2010, 07:58 AM
Simple as above. I have it maxed out at 15 parachutes in inventory and I can't buy anymore in stores either.

The problem is when I hit RB it does not show in the lsit of weapons/items. I know I manageg to use it on couple of occasion as it would arndomly pop up when jumping under X.

It's been a while since I've seen it last and now I can't get it to work at all!! I even tried jumpig off the top of Castelo and only succeeded in breaking Ezio's every single bone!

Any help would be appreciated!

11-24-2010, 08:06 AM
To be honest I find the parachute to be little more than a gimmick...does anybody EVER use it?

Anyway, you don't need to equip it. As long as you have at least 1 parachute, when you jump off a building you should be able to activate it by tapping X, even if it doesn't give a pop-up telling you to do so.

I tried jumping from a few of the smaller buildings just then, and it seems that if the fall isn't great then the parachute won't deploy :\

11-24-2010, 08:15 AM
Same problem, i end all the "L" mission and got the parachute, then the item appear above the hidden blade icon when i purchase in the store, but when i try to use nothing happend and when i exit the animus and go back i lost all my parachutes......This tiny details and the others bugs are really starting to make me mad and im really starting to think the game is not complete after all....This remind me a lot of Gears of war 2, at the very early 1 week after launch the game, they must upload a patch to fix massive bugs and other stuff...

Dissapointed level=2

11-24-2010, 08:21 AM
Yeah there's something weird about the parachutes, they seem to disappear from my inventory every now and then, so I buy new ones and when I find myself in need of deploying one, I suddenly don't have any. http://forums.ubi.com/images/smilies/51.gif

11-24-2010, 08:27 AM
The parachutes are very glitchy. If you leave the Animus and come back in they disappear. I've also heard complaints that they can get in you in weird places that cause the game to lock up.

To use it you have to be in mid air. Hold x until it opens. Hit B to drop off it. You can also assassinate from it by hitting x again if you are close to a target.

11-24-2010, 11:43 AM
There is a new patch which solved the problem for my ps3 (and our xbox).They still disappear from your inventory hud but you can use them after rapid movement and all other things...

04-06-2019, 07:51 AM
I am stuck in AC Brotherhood at Copodoglio guard assassination from top of structure. Parachute will not deploy as I attempt kill. Do I need patch or is there another entrance for kill ????