View Full Version : Problem with the Saitek 52 joystick minimouse and IL2 1946

02-25-2008, 10:03 PM
I have run into a problem with my Saitek 52 joysticks minimouse feature. It was working fine on IL2 1946, but has now stopped working. The Saitek diognostic shows the buttons themselves work just fine, but the game has stopped recognizing them. I was wondering if anyone else has encountered the same problem and if a fix may exist?

Thanks for your time

02-25-2008, 10:10 PM
Reload the HID drivers for them.

02-26-2008, 07:04 AM
I have reload everything twice to no avail. I even tried reloading the game. No go.

02-26-2008, 07:32 AM
um possibly try resetting controls to default, or create a new pilot with default controls, and reset all the profile set up to defaults. could be that you have assigned it to multiple functions? done it myself a couple times with the x52 set up and controls...

02-26-2008, 07:58 AM
This is a problem with the firmware of the X-52. Some get the drifting mouse effect some just get the no mouse effect.... guess your the later...

On my X-52 I had to manual desable the mini mouse from the control panel... because I was getting the drifting mouse...

Seems that the HID and XP mouse driver are "fighting" for control of the mouse... with weird and un expected results....

02-26-2008, 08:12 AM
Thank you gentlemen for the suggestions. I will give them a try and see what happens.

02-26-2008, 01:12 PM
Well I tried everything I could think of. I contacted Saitek and they said to try to completely uninstall 1946 an manually delete the folders left behind by the uninstall program. Did that, then did a complete reinstall of 1946 and guess what? WRONG!!! It did not fix a thing. 1946 still refuses to recognize the buttons. Wierd since it recognized them not more than a week ago.

02-26-2008, 01:19 PM
Select your profile and open notepad, start hitting buttons and see if it types the corresponding keyboard key. If it types the key then theres something wrong with the game. If it doesn't type the keys then there is either something wrong with the stick or the profile. As for the minimouse I have no idea but if the profile software is not working right perhaps it has the minimouse turned off.

02-26-2008, 01:24 PM
Hi, I had the same problem a month or two back.
I didn't reinstall or anything. I'd been messing about thinking I had a conflict, and I'd disabled something in the computer.

I'll have a look and get back to you, and try to find what it was I'd switched off.

02-26-2008, 01:37 PM
Hi again,
I found what it was for me, worth a look.

Start-settings-control panel-system-Hardware device manager-Mice and other pointing devices.

In the same area, there is also Saitek magic bus. Under that heading is Saitek magic mouse.

I had knocked it off thinking it may have been conflicting with my normal mouse. That did it for me. Hope it's as simple for you.

02-26-2008, 02:38 PM
How about unplugging the mouse?

02-27-2008, 08:13 AM
OK gentlmen,
I looked into everything you have given me so far with no result. Sorry. I am at a complete loss.

02-27-2008, 08:14 AM
Oh BTW I even tried updating the drivers from the Saitek site. The ones on the disk were newer than the ones from the sight.

02-27-2008, 08:27 AM
Be advised: You cannot load the old profiles with the new program-versions! I learned that the hard way. Also the profiles are no longer stored in the program-folder. Also learned that too late.

What are you using the mouse for in IL2? If you are using it for mouseview, for example, well,
just a silly question, but you didn't by chance disable mouse-view or enabled view-snapping (F9) or something in IL2?

02-27-2008, 10:47 AM
How do you disable mouse view? i am using F9 now because i can't get the minimouse to work.

02-27-2008, 11:04 AM
I've never been able to get the minimouse to work. And because some say it drifts, I'm in no hurry to even attempt to get it to work. Instead, I have a TIR on the way.

02-27-2008, 11:09 AM
well, if you can look around with your normal mouse, that would be an easy way to check this. I disabled the mouse-view once, by fiddling around in the conf.ini. Dunno what option it was, but if you cannot move the view with your normal mouse either, it's no Saitek-Problem.

You can also check your mouse-speed in the configs menu (Hardware-Setup -> Inputs -> lower right side) There should be a 1.0 as default.

02-27-2008, 01:04 PM
Well i don't think it's the config. I did a complete uninstall including manually deleting any files dealing with IL2 and did a fresh install and it still doesn't work. I don't think it's a saitek problem either becasue it works in the saitek control panel. When I had the X45 i was able to disable mouse view for the JS but cannot for the life of me figure how i did it or why it's not working on the X52.

02-27-2008, 07:28 PM
Hey gang I really appreciate all the help you gave me. I finally got the problem fixed. It was right under my nose the whole time and it only took me 3 days to figure it out. the ministick was conflicting with IL2 and another game I had installed. When the other game was removed (OPERATION FLASHPOINT) everything was right with the world again. Thanks again folks.


02-28-2008, 02:43 PM
Glad you got it sorted, frustrating at the time, but worth it in the end.