View Full Version : Stuck at Leonardo da Vinci

03-06-2010, 01:24 AM
I just started playing the pc version at the game, but when I go visit Leonardo for getting my hidden blade fixed, I am told to equip it. When I equip it, nothing happens. The game just stands and waits like I haven't equipped it, even though I have. It haven't frozen, but just seems to be there waiting for me to equip it.

Anyone have a fix for this?

03-06-2010, 05:01 AM
I have the same problem. It's not completely crashed - when you open and close your inventory you can see his hair moving.

Very frustrating.

03-06-2010, 08:43 AM
It helped me to hit '2', as it is the default button to instantly equip HB.
Hope it'll help you too.
It was very frustrating- I reboted the game twice :/

03-06-2010, 02:27 PM
Originally posted by MasterMedwith:
It helped me to hit '2', as it is the default button to instantly equip HB.
Hope it'll help you too.

Did you guys try this and did it work for you?

03-07-2010, 01:02 PM
When i first started the game, the first thing I did was remap some of the hotkeys (in particular, the weapons hotkeys) << My weapons for AC1 are all keyed to the number pad on the right of my keyboard, with Num 1 = throwing knives, Num 2 = HB Num 3 = sword/short blade and Num 4 = fist.

For AC2, my weapon hotkeys are Num 1 = HB, Num 2 = Fist and Num 3 = sword (which i was disarmed of by guards and hence lost it :P)

You just have to make sure you press whatever hotkey the Hidden Blade has assigned to it. Worked for me imediately.

03-09-2010, 08:34 AM
Is this the same issue I have. I am at Leonardo's and have been asked to carry the box for hom, but I am unable to pick the box up! I'm stuck. I've uninstalled the game and started from scratch but end up with the same issue. What am I missing?

03-09-2010, 01:15 PM
I am having the same problem as Haggis50. I cannot pick up the box from Leonardo. I have moved it around the door way, pushed it out onto the street, restarted the game. When I'm near the box the indicator in the upper right corner does change from Gentle Push to Pickup Object. But pressing the button just makes him perform the Gentle Push action. That something like this pops up so early in the game play does not speak well of your QA team.

03-09-2010, 03:55 PM
Are you PRESSING or TAPPING the button? To pick up the box, it is advisable to merely tap the button.

03-10-2010, 09:40 AM
I had the same problem when I had to pick up the box and take it home. You just have to press the botton you use for Gentle Push when it turns into Pickup Object, and hold it until you pick the box up.

03-10-2010, 09:46 AM
Thanks all for your replies, I just tapped the button as suggested by Kraschman2010, and it worked! Previously, I was holding the button as though I was collecting coins! Thanks again.

03-10-2010, 11:03 AM
I am having similar problems. Is there a guide for the equivalents for the keyboard control equivalents. I am having difficulty syncing the keys on the board to the PS symbols.