PDA

View Full Version : Lost my main weapon...



zonark7
11-26-2009, 07:22 PM
Ok so I just purchased the scimitar from a blacksmith in the Villa. I went to go try it out in the practice area in front of the Auditore's house. When I selected to try practicing combat against a brute, I pulled out my sword, and instead of it being the scimitar I just bought, it was the common sword that I previously had. When I left the practice battle, the scimitar was still not there. I went to the blacksmith and talked to him, went to the weapons area, looked at the scimitar, and it said "Already Equipped" under the description. I then quit the game and reloaded it, and the scimitar was still not there, just the common sword. I went into my inventory in the start menu, and there was no scimitar in the weapons section, even though at the blacksmith, it said that it was already equipped. So now it seems that I just wasted 10,000 florins for nothing...

Has anyone ever experienced this sort of problem and can help me out? If not, hopefully the devs will fix this in an update soon.

Gandalf-the-Fab
11-26-2009, 07:31 PM
Honey try equiping another weapon then re equiping the scimitar.

zonark7
11-26-2009, 07:33 PM
I've tried this, but the common sword just remains in place of the scimitar.

zonark7
11-26-2009, 08:05 PM
I figured Ubisoft would do something stupid, they always do.

Datashocker
11-26-2009, 08:43 PM
Try this; Go to the training place and select the "pick up weapons" tutorial. After finishing this you should have no sword weapon on you. Go to the weapons room and try and equip your scimitar. If you need more explanation i can make a video. Let me know if this works.