PDA

View Full Version : MS Sidewinder Precision 2 Stick stops working-how to restart it?



drose01
06-18-2005, 02:21 PM
I am the usually satisfied owner of a MS Sidewinder Precision 2 joystick but am having a problem (which I have had before).

The stick just stops working. It is not recognized by the computer at all, despite a system reboot, unplugging it from the USB port,changing ports, trying to configure in control panels, add hardware, etc.

The exact same thing happened about 11/2 years ago. I nearly threw it away, thinking it was defective. But just before I did, after it sat for a couple of weeks, I retried it one last time and ... it was working perfectly again, and worked for the next 11/2 years without a problem.

I seem to recall reading some post here sometime later in which someone was describing having this problem too.

My question is, does anyone know what causes this problem, and does anyone know how to fix it besides just putting it aside and waiting for some unknown period of time?

(I seem to recall, maybe, that it has to do with static electricity buildup or something like that...)

drose01
06-18-2005, 02:21 PM
I am the usually satisfied owner of a MS Sidewinder Precision 2 joystick but am having a problem (which I have had before).

The stick just stops working. It is not recognized by the computer at all, despite a system reboot, unplugging it from the USB port,changing ports, trying to configure in control panels, add hardware, etc.

The exact same thing happened about 11/2 years ago. I nearly threw it away, thinking it was defective. But just before I did, after it sat for a couple of weeks, I retried it one last time and ... it was working perfectly again, and worked for the next 11/2 years without a problem.

I seem to recall reading some post here sometime later in which someone was describing having this problem too.

My question is, does anyone know what causes this problem, and does anyone know how to fix it besides just putting it aside and waiting for some unknown period of time?

(I seem to recall, maybe, that it has to do with static electricity buildup or something like that...)

Brass_Monkey
06-18-2005, 03:29 PM
Check both ends of your power cord.

Esquire_1
06-18-2005, 09:25 PM
My Precision 2 joystick has'nt been recognised by my computer for a couple of years now since I installed CFS3 (and promptly uninstalled waiting for the bugs to be taken out!). IL2 has been the only game to recognise that it even exists since then .... go figure?

Firstly there was a static build-up thing going on ... to (possibly) cure the problem un-plug and plug-in the USB plug about 30 times then re-boot ... even try it without the computer on ... I dunno .. did'nt do it for me but some have said it works.

Or ...this is the tricky way to (possibly!) cure the problem ... if you're not keen on editing the registry do'nt go there ... although if you follow the details carefully you can't go wrong.

SideWinder USB Port Controller Reports "Not Connected" Status http://support.microsoft.com/default.aspx?scid=kb;EN-US;216096

There are other fixes ...just search for them on the MS site.

As I said earlier ... my system still reads as un-connected but as I've only played IL2/PF since I gave up trying to fix it and just carried on playing the game.

Good luck andlet me know if you find anything interesting ...


Cheers Esq.