View Full Version : TCP & UDP Port usage for online play

12-15-2006, 12:11 AM
Listed below are the ports that R6:Vegas uses to connect to the internet, so you can unblock them for multiplayer. This may not be all that you need to do -- personally, I had to turn off my entire Norton/Symantec protection -- but it should help. Quoted from a tech support response.
Response (Jason) - 12/14/2006 06:48 PM
The following ports need to be open in your router/firewall to be abe to play Rainbow Six: Vegas online:
TCP : 80, 3074
UDP : range between 3074 and 3174

If you continue to have trouble playing online, please make sure that you have the latest firmware updates for your router from the manufacturers website.

Good luck...

12-15-2006, 12:11 PM
Any other suggestions?

My router linksys wrt54g router works great with all other games and port forwarding, but not this one. It works if I hook directly to the internet but not through the router. I even tried putting the server in the DMZ but that didn't work. I am on FIOS if that matters. I know they block port 80 from unsolicited incoming packets to prevent web hosting, but since my server works fine when hooked directly, I doubt this is the problem.

12-15-2006, 01:26 PM
Good question. It might be your firewall, as always. My Norton/Symantec needs to be ENTIRELY shut off (not just allowing program access or even disabling personal firewall), and I still have to click it twice to log in (it always fails on the first try).

To be honest, I'm on a university network, but I have verizon fios at home (which is AMAZING for gaming and downloading!), and I'll find out in less than a week whether R6V works there as soon as I get home from final exams. I haven't had any problems with fios that I didn't have with regular old DSL routers, if that helps any...

12-20-2006, 12:06 PM
It works fine with my fios at home. In fact, I actually get online on the first try (as opposed to the second on my university's network). I'm still encountering some multiplayer lag, and now I know that it must be server-side, because with 2.15 megabytes/sec and some good percentage of that up, it sure as hell isn't on my end.

12-29-2006, 01:57 PM
Even with Norton disabled get "Failed to initialize".

With the exe set-up like so:

Protocol TCP UDP, Communications; In Out, Computer All, Adapters All

It still don't work

12-30-2006, 12:48 PM
May be your router or whatever network you're on...you have to go to the main Norton status page, select "Security" (all the way on top), and click "Turn Off" on the bottom right, at least in my version. That disables EVERYTHING from Norton. If that doesn't work...are you on someone else's network or your own router at home?

12-30-2006, 01:58 PM
Tried what you said, click on status & settings > Security > "turn off" button on the right. Still "failed to Initialize Network Service"

It also doesn't work if I right click the Norton icon (in system tray) and select disable.

I don't know what else to try, I've tried adding ports, tried allowing all ports, tried disabling SSDP and UPnP in my Router manager. Even tried disabling SSDP, UPnP and Norton, still cannot get online. And even checked to make sure the Windows SP2 firewall isn't enabled.

I blame that bloody Demonware, absolute sh1te http://forums.ubi.com/groupee_common/emoticons/icon_mad.gif

12-31-2006, 12:43 PM
Man, that sucks -- it sounds like you've tried just about everything. I would try your luck with UBI support after you try one more thing: set yourself up on a fixed IP (if you aren't already) and put that IP in your router's DMZ. Basically, the router doesn't filter anything going to that IP. Be warned, though -- the router normally filters out a surprising amount of malicious stuff. I used to have to put myself in the DMZ to play Homeworld2 and Norton would pop up every hour or so with a "I blocked this trojan or that worm" warning.

Also, as stupid as it sounds, make sure you have the 1.2 patch (maybe download it as a standalone, reinstall, and patch). Not only could that cause you not to connect online (because of the wrong version), but it might also contain outdated netcode.

Other than that, I'd try my luck with noobysoft support.