View Full Version : Memory 3 part 1: No assassin apprentice to send on first "Mediterranean conquest"

11-19-2011, 10:48 AM
Hi guys,

I'm stuck ... and the support guys insist this is not a bug but a gameplay problem ... maybe you can help?

If the one recruit you make in memory 2 gets killed there is no way to progress through memory 3 part 1 and there doesn't seem to be a way to make new recruits at this point in the game ... when accessing 'Guild contracts' the one assassin at level 11 that you have appears on the menu but you cannot select him for the mission and if you press O to exit the menu ... you cannot and have no choice but to quit the game ... I have tried this three of four times to make sure ... I've looked at gameplay forums but there doesn't seem to be an answer there either.


11-19-2011, 10:51 AM
I believe you might already be able to get more recruits. However, for me they didn't show up until I returned to Animus Island and went through the gate again, so try doing that and see if the recruit missions show up on the map.

11-19-2011, 11:22 AM

Thanks LightRey I'll try that ...

Why isn't Ubisoft addressing this issue though?


11-19-2011, 11:31 AM
I'm not sure. I guess they never expected that someone would lose a recruit that early, similar to how they never expected someone would use the fast travel system in ACB to go to a place that was closed off before they were explained.

11-19-2011, 12:22 PM
Er ... I tried and went back to Animus Island ... and did some of the apalling Jesmond Journeys (I mean ... seriously!) and back in the game ... nope ... still stuck!

I conclude that this game sucks ... not starting again ... what is the next bug going to be ... really dissapointed especially since I really liked Brotherhood ... thanks anyway LightRey!