PDA

View Full Version : My IL2 1946 Became Dead



vonbikia
01-08-2008, 03:45 PM
I forgot the key word I used to request last time. Still cant find my answer. My IL2 1946 shows the symptom like many others'. When you double click the desktop icon, it will show a CD cursor spinning, then nothing happens. I saved the IL2 series in the past by all kind of method, adding the rst.dll, deleting the registries and reinstall. I still have no clue how I succeeded in history, because they always just pop out and work suddenly. But this time, I have a feel that it got me.

I have contacted SecuROM for analysis, they have said my securom is ok.

My rouph conclusion of how IL2 series installed successfully is because your system is setup soundly. Like you don't neglected some VIA chipset drivers. Seems IL2 will utilize this facility. It had seemed make very clearcut distinction of if the game will response or not.
But now here is the trouble. My motherboard is a second hand backup, with no factory drivers. I just use my old motherboard's drivers, because the retailer informed me they are all VIA chips, and will be compatible. And My Win 98
just experienced a reinstall, with the system kept alike. While the other things functions well, the IL2 1946 is gone.

I try to ask the UBI support, but it's very funny that when I log in for asking a question, it will repeatedly return to ask me to log in. But I'll think ask my question here will be more effective. So, I encouraged myself to make a post.

I'll keep searching the discussion for a clue, although in fact I am really not so vacant for this enormous task. There are all kind of suggests which any single one could be vital. I wonder why some intelligent one could not make a "tree" guide, which resembles the microsoft if-then flow chart in their textbooks. Through many post in the forum, I can see those problem solver are far more confident and experienced. This can assemble all the level of emergency and priority of readers who are in need of help. I believe it will make the problem solving of IL2 series a more systemmatic and easier job.

System description:
CPU: AMD 1.6G
Mem: 512M
Graphic card: ATI Radeon 9250 128M.
Sound: on-board AC97.
DX: 9.03c.
OS: Win98SE.
DVD: Asus 18X DVD-ROM.
with Alcohol52 virtual drive, IL2 ver: already updated as 4.08m.

Redwulf 32 - Nis
01-08-2008, 03:53 PM
with Alcohol52 virtual drive, IL2 ver: already updated as 4.08m.

You still have the 1946 DVD you bought, right? Remove and reinstall = no problem. Or did you do "something else"?

vonbikia
01-08-2008, 04:02 PM
Sorry I didn't see my post listed in the discussion page. To re-install is the thing I gonna do manytimes in the next few days. Don't suspect I'll do anything else like make an image file. With software so picky like IL2, I'll use the extremest safe and guaranteeing way to install it.

vonbikia
01-08-2008, 05:53 PM
Thanks for Redwulf to reply so soon. I reinstall it once again with regular procedure, no touching the registry. I know it's still useless, the game still cant start.
There is one very strange phenomenon, the remove, take 30 minutes sharp, install, 10 minutes. This is the first sign of trouble for installation of IL2 games. There must be something hanging inside the system.

I found there is a trivial scratch on the DVD. But when I use my sealed first CD to install it, the behavior is all the same. I multiply purchased the 1946 because I'm going to collect it as a lifetime assets. Besides money, I'll pay as well as time.

Redwulf 32 - Nis
01-08-2008, 05:59 PM
Originally posted by vonbikia:
Thanks for Redwulf to reply so soon. I reinstall it once again with regular procedure, no touching the registry. I know it's still useless, the game still cant start.
There is one very strange phenomenon, the remove, take 30 minutes sharp, install, 10 minutes. This is the first sign of trouble for installation of IL2 games. There must be something hanging inside the system.

I found there is a trivial scratch on the DVD. But when I use my sealed first CD to install it, the behavior is all the same. I multiply purchased the 1946 because I'm going to collect it as a lifetime assets. Besides money, I'll pay as well as time.

Ok, I notice you are using Win 98. Although Win 98 runs IL2 slightly faster than XP (thinking AMD 1.6 here), Win 98 does have a tendency to "bit rot" i.e. it will, over time, get slower and slower and weirder and weirder. I'd advise a fresh install of Win 98 *or* get XP and then do a, likewise, fresh install of 1946.

Hope this helps.

BTW, try posting in "Community help", lots of nice people there with considerable experience in tackling "funny" issues.

cya around

M_Gunz
01-08-2008, 07:11 PM
I can recommend getting a pack of D-Skins and put one on the IL2 DVD to avoid scratches.
Also getting Nero and running Drivespeed to slow the player down and avoid disk stress.

Lastly mobo is 2nd hand backup -- why you can't download the latest drivers even if you had
a factory disc? Find writing on the board and search those out if you don't know what mobo
it is.

vonbikia
01-08-2008, 10:29 PM
I'm interested in what is D-skin, and I'll find if our market have such things. That's the good of attending a prosperous forum. Thanks!

mortoma
01-09-2008, 06:29 PM
To me it sounds like you have one of the CD/DVDs with securrom on it. I could not get that to run in Win98SE at all. Once I downloaded 1946 from the intenet it runs perfect on Win98!! Downside is that I had to buy the game two times. But hey, it makes Oleg richer so he has more money to spend on BoB/SoW!! The downloaded version is only 20US. But it's only available in the US IIRC. Maybe Canada and Mexico too.

mortoma
01-09-2008, 06:32 PM
vonbikia, I have sent you a PM, please read it.

vonbikia
01-09-2008, 06:36 PM
I found the receipt of my mobo, besides, the bios start up also will show it. Finally I install the factory drivers of my system. The very discouraging result is it still didn't work.

I have forgot one very important fact. The behavior after the spinning CD cursor has followings. After 10 minutes or more, the native Windows error message comes up: "The program is erroneous and gonna close, please consult your software programmer". The dump detail is:

IL2FB caused an invalid page fault in
module IL2FB.EXE at 01af:00767b5b.
Registers:
EAX=00000000 CS=01af EIP=00767b5b EFLGS=00010206
EBX=00000000 SS=01b7 ESP=00f3f6ac EBP=00f3f6f4
ECX=00000098 DS=01b7 ESI=00000000 FS=304f
EDX=cc4452ff ES=01b7 EDI=00000006 GS=0000
Bytes at CS:EIP:
8b 46 18 b9 98 00 00 00 3b c1 57 0f 8f b2 07 00
Stack dump:
00be2162 00000000 77767574 7b7a7978 7f7e7d7c 20202080
20202020 20202020 20202020 20202020 20202020 20202020
20202020 20202020 20202020 20202020

it seemed from this message that SecuROM judged that the problem is in the software, instead of securom. Is anybody seeing this condition before? Please give me some guidelines for my next steps. Thanks!

vonbikia
01-09-2008, 07:25 PM
The Download version is a nice choice, because in the long run, I'll highly likely to buy a 3rd backup. But only if it really functions.

I think Win98 system gonna accompany me for several years if things went right. I hope there is also Eastern Asia version to buy.

vonbikia
01-11-2008, 08:48 AM
These days, I performed several steps. Still no outcomes.
1, Defrag the HD
2, use Windows Control Panel remove IL2 1946
after the IL2 uninstallation.
3, Update my VIA chipset drivers to newest.
4, use a.exe instead of setup.exe

About the "Tree Chart", I have deviced a design called "Help Chart". It can help the problem and in the mean time poll on the effective moves. When one asker is solved, this chart will pass to another new comer and keep develop all the time. It will like a phalanx to eventually setback the bugs.

Because I can't do HTML programming, maybe somebody can make it a running java or something.

Here is my situation:
<span class="ev_code_PURPLE">Defrag</span> ---
<span class="ev_code_PURPLE">Use a.exe</span> ---
<span class="ev_code_PURPLE">delete registry</span> --- ->Win Program Error
<span class="ev_code_BLUE">update VIA(50)</span> ---
(succeed: fail =1:1)

Detailhttp://forums.ubi.com/groupee_common/emoticons/icon_frown.gifupdate VIA),
if motherboard is not setup completely,
it will stop IL2 FB from running. The
symptom is often a very delayed prog-
ress in install.

The chart has different code colors, means the significance of this act. It can accumulate as the user record the success or failure of the practice. Success, one vote, failure, one negative. Maybe when minus till some integer then the term will disappeared.

And each term has to be a denote details, which will describe and explain what situation is in the term.

Hope this will help. I already put 1946 as an dispensible. It's already undermining my time and daily life.