View Full Version : Help! Brutus Armor Bug/Glitch

11-27-2010, 09:55 AM
this is really annoying!!!! i was able to complete sequence 8 memory 4, i got all the keys for the romulus lair...then i started sequence 8 memory 5, the location of the the main mission was close to romulus lair so i decided to pick up the brutus armor set using all of the keys, while i was holding the apple of eden...
then after i equipped my new armor i went on continue the mission, because i was notorious at that time i had used always the apple of eden to kill all the enemiess after draining all of my health, one soldier with a gun killed me, the i have to try again but when i spawned outside the lair of romulus, i got reset back at my previous armor, the armor i was wearing before i claimed and equipped the brutus armor...so i tried looking for it but i could not find it in my inventory, ezio's hideout, lair of romulus..so i just went and finished the whole game, after completing all the sequence and just free roaming...i still could not see that brutus armor...its still missing, the middle manequin in the armory inside ezio's hide out is empty also, the romulus lair..is there any way to FIX this?? this is the only bug i have experience that really is so much frustrating and annoying...

somebody help me please..

11-27-2010, 10:27 AM
help me please...anyone??

11-27-2010, 11:03 AM
Hi there! Have you contacted Ubisoft Support with your issue? http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

11-27-2010, 11:31 AM
yes i have already...but still no reply...

11-27-2010, 11:33 AM
OK! I'm sure Support will get back with you soon. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

12-02-2010, 01:11 AM
From what I can tell, this is moderately prevalent. Yes, I, too, suffered this bug, and it sucks.

I think it has to do with the fact that you are forced to use the Apple by making it the only equippable weapon near the end (not sure I like that). When you acquire the Brutus Armor and Dagger, you are automatically equipped with the dagger. When you try to switch back to the Apple, the game has a fit because you aren't supposed to be switching from anything to the Apple.

12-02-2010, 02:36 AM
My suggestion for anyone reading this thread...

Don't start a memory while you're already inside another memory. When you start a memory, you're supposed to finish it, then do another one. I imagine it would be helpful if the system locked out all other memories while inside one already, but obviously the programmers didn't expect anyone to try something like that.

12-02-2010, 07:13 AM
Any word if this bug will be fixed? It's understandable to be overlooked by programmers, but this is a big issue for several people, especially if they experienced this bug near the end of the game.

12-02-2010, 09:27 AM
That's the thing, Dougout, the game actually does lock out other memories from starting. Acquiring the Brutus armor, however, simply acts as an item, not a memory.

12-03-2010, 12:05 AM
Originally posted by Winged_One:
That's the thing, Dougout, the game actually does lock out other memories from starting. Acquiring the Brutus armor, however, simply acts as an item, not a memory.

It's my understanding that any item on the map that has a diamond around it is considered to be a memory by the programming. That's kind of the whole point of the game... replaying memories from an ancestor.

12-05-2010, 06:03 PM
I'm nearly certain the armor functions as a special type of treasure chest. There isn't a memory start location for it, nor is there a specific name for the memory. There isn't a small statement of the objectives or an accept/decline option.

Compare this to the secret Romulus locations, which do function as memories.

01-03-2011, 09:15 PM
i had this problem as well. it is incredibly infuriating. is there a way to fix this without connecting to xbox live?