PDA

View Full Version : IL2 1946 DVD is not recognized on my PC - Explorer gets stuck



trefalc
04-06-2007, 07:43 AM
Hi,

I just bought the IL2 1946 DVD in the UK. My PC has got an old DVD drive and a CD-RW drive.
I put the disk in the DVD drive (Dhttp://forums.ubi.com/groupee_common/emoticons/icon_smile.gif and it just spins.
If I try to open the explorer, it doesn't show anything, just an empty window, no C:, no D:, no E:.
What's going on? Is there anything I should do?

trefalc
04-06-2007, 07:43 AM
Hi,

I just bought the IL2 1946 DVD in the UK. My PC has got an old DVD drive and a CD-RW drive.
I put the disk in the DVD drive (Dhttp://forums.ubi.com/groupee_common/emoticons/icon_smile.gif and it just spins.
If I try to open the explorer, it doesn't show anything, just an empty window, no C:, no D:, no E:.
What's going on? Is there anything I should do?

WWSpinDry
04-06-2007, 07:45 AM
Any way to see whether there are newer drivers for your DVD drive you can download? I've heard a lot of issues with older drives and the copy protection on the DVD.

FoolTrottel
04-06-2007, 10:14 AM
IL2 Sturmovik 1946 and DVD-Drives (http://forums.ubi.com/eve/forums/a/tpc/f/49310655/m/4391008415)

slappedsilly
04-06-2007, 10:48 AM
I have had problems before with earlier versions of the game. Make sure your dvd drive is enabled. Some how, mine became disabled.

trefalc
04-09-2007, 03:44 AM
Thank you for these tips.
I checked everything, and my DVD drive actually says CD-ROM when I look at it in Explorer.
Strange! I didn't notice before.
On the other hand, I bought Far Cry on DVD and it installed off DVD, so somehow, it works with some DVDs. It was a bit hit and miss, though, working sometime, not working others.
I wonder whether I need to reconnect my DVD drive some other way. I may also try and take it apart to see if it needs cleaning.
Any other thoughts?

Troll2k
04-09-2007, 05:35 PM
You might try going to the dvd manufacturer's website and see if there is a firmware update.

trefalc
04-10-2007, 01:19 PM
Thanks for the pointers. The firmware update for my old Samsung SD-608 was done a while back (version 2.4). Now on the Samsung website there is neither firmware nor specific driver for this.
I may feel obliged to go out and buy a new DVD player just in case.

Sandman_UK
04-10-2007, 01:52 PM
Dont rush out and buy a new drive for nothing. Someone posted a link a couple of posts above to the Drives problem in the forum.

I had exactly the same problem yesterday, my drive could see it was a DVD and that it was IL2 46 but would not run it. I installed the firmware and still nothing.

The key is can you explore the DVD? if so then you have 3 things to click in the main folder that may get it going.

I think it was a.exe that got it going for me. But like i said, its all posted in that forum page from the link above.

Hope it works for you, as im not convinced a new drive will get you past the problems. I have a Sony and plextor Drive in my machine and neither could get it to run.

MaxMhz
04-10-2007, 02:17 PM
If you can explore the DVD, check if a.exe will start the install - Alternatively run autorun.exe in one of the numbered folders on the DVD. The autorun feature on the 1946 DVD is buggy as the warm place so many dictators live in http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif
check here (http://forum.rpc1.org/dl_firmware.php?download_id=162) for Samsung SD 608 Firmware.
I should note many people have reported problems with this drive - just do a google, plenty hits on it http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif
No need to take the drive apart - other people report the same troubles; sometimes working other times not. http://forums.ubi.com/images/smilies/compsmash.gif