View Full Version : [Graphical] Instant crash at begining

03-09-2011, 10:53 AM

Before you start misunderstanding on my issue, here is my system :
Win7 x64
Intel i5 quad core 2.66ghz
ATI Radeo HD 4800 Series 1go (1024mo)
2go ram DDr3

So my computer isn't the problem. I've bought and installed both AC 1 and 2. I just finished the 1 this night, without any trouble, working fine with DirectX10 (because I like to play in window mode). Then I started AC 2 via Steam (I've bought it on steam, both). It first update directx, no problem. Then it installs the launcher : no problem. Then it installs VC Redist (Visual C++, it was the 2008 x86 package by default) and it was way too long then I installed the latest version (2010 x64) via the official website of microsoft and I restarted the game (updating, by the way, the file in the /redist/ folder of the game). It starts the launcher, I create my Ubisoft Account, I log in, and I validate the game, and I click on " play ".

And then it's the big bang attack :x My screens gets black with 1/4 of it white (the top-left quart) and it flashes every... 2 or 3 seconds. ALT + TAB doesn't work. ALT + F4 doesn't work because each flash make it back to the game. I had to CTRL + ALT + SUPR, open the task manager and playing with the ALT + TAB between each flash to click on the process (AssassinsCreedIIGame.exe) and terminate it.

Since I've done absolutely nothing on it (simply download and start !), I'd REALLY like some help on this issue in order to be able to continue the AC saga >.<" (the end of the 1st was kinda sad : at the end I couldn't open the computer of the meeting room because I havn't stolen the doc's pen at the begining so I'm wondering about restarting it xD but it's an off-topic =P).

Thanks to anyone who could lead me to fix it :/ I gonna try to download and install the latest version of DirectX (DX11) since I dunno which version was with the default package and I'll see...

03-09-2011, 11:17 AM
If installing the latest version of direct X does not help - can I suggest you contact Ubisoft support?

You can contact them via details in the game's manual - www.ubi.com (http://www.ubi.com) or using the direct weblink in my signature.

03-09-2011, 11:34 AM
AC2 only uses DX9, so downloading the latest DX10 or 11 drivers isn't going to help anything. Are your GPU drivers fully updated? Might want to try updating those on the ATI website. Other than that, I've never heard of a problem like this.

03-09-2011, 06:38 PM
Thank you both for your quick reply and sorry for the wait : I had trouble to restart the game (due to my connexion troubles, it happens http://forums.ubi.com/groupee_common/emoticons/icon_razz.gif) and I didn't wanted to answer for nothing.

So... I've updated Direct X to the latest version (June 2010, available on Microsoft Website). My GPU is also up-to-date. I've installed Microsoft Visual C++ 2010 (either x64 AND x86) and even the 2008 version (x86) which is included in the default package.

Result : nothing changed. I followed Shade's advise and went directly on the Ubisoft's support. I hope they'll be able to provide me some help to fix this ******* bug :O

By the way, thank you both for your help. If I find what I have and how to fix it I'll reply in order to share the answer. I just hope we'll find it >.<"

EDIT : ANSWER : I finally fixed it. I swear you won't believe it... This big bug was due to an incompatibility with my screen resolution (default : 1680*1050px). I tried to set my desktop on 1600*1200 and I achieved to start the game without any trouble. I changed the default resolution in the options of the game and it seems working. I hope there'll be a fix because I'm almost sure that none else will find the answer on his own except with specific graphisms and informatic skills :x

You should have seen my screen flashing every second... Who could have believe all this had started with a simple incompatibility of resolution :/

Thanks for your help anyway =P

03-09-2011, 07:08 PM
Well, welcome to the Forums! http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif