PDA

View Full Version : New Dlls for 4.09b



GH_Klingstroem
01-30-2008, 02:00 AM
Im cant figure out if these are official or not?

Changes in comparison with 4.09b core
Read description.

An attempt was made to reduce freezes
- Calculation of fog was moved from CPU to GPU (beneficiary for powerful GPUs and weak CPUs) Note: There is possibility of errors. If you notice flashing of bright red, please record track.
- For nVidia 8800 series amount of memory allocated for textures of water was reduced on 16MB without loss of quality.
- A bug was discovered in the water=3, water=4 modes, now render of water should be faster
- Increased smoothness of water geometry near the surface (less then 15m altitude)
- Corrected old bug where various textures could be replaced by texture of ground (sun reflection on the water would become yellow)
- LandGeom=3 mode was optimized for less memory consumption (25% less)
- Improved filtration of textures on the distance reduced "vibration" of the textures along the rivers.
- Removed trees that were growing out of the water on the new maps.


It would be great to try new DLL on the different regimes of Perfect and non Perfect modes, water=0,1,2,3,4 and ForceShaders 1x=0,1; LandGeom=2,3.
How much faster is current version of DLL comparing to 4.09b?
Also, if you seeing blue spots on the plane from external camera (there were screenshots of that on the forums), please send me a ntrk file and your conf.ini


Installation of DLL`s.
In the main IL2 folder -
Rename current il2_corep4.dll to something else
Rename current il2_core.dll to something else

Unzip new DLLs to IL2 Main folder.

http://mission4today.com/index.php?name=Downloads&file=details&id=3246

Cheers

x6BL_Brando
01-30-2008, 04:37 AM
Yes, they are official - first announced by CrazyIvan on the IC forum a couple of days ago. They are only pertinent to the 4.09beta version.

My first impression is that they have improved the already-good running of the graphics in the beta. I'm using an x2 4600 AMD cpu/ Ati 1950pro512Mb/ 2 Gb RAM/ XP Pro system and I've detected none of the artifacting mentioned in the readme.

Definitely worth trying, if you are using 4.09b

B

Aviar
01-30-2008, 11:37 AM
An even newer set of dll's is coming soon, so stayed tuned.

Aviar

GH_Klingstroem
01-30-2008, 10:58 PM
nice!!

knightflyte
01-31-2008, 01:32 AM
Originally posted by knightflyte:
I'm running an ATI 1650 with 512 of ram on the card. I have Intell duo core 6700, and 2 Gigs of memory.

With the new DLLs tehre seems to be no/minimal draw in while flying around cities now, but distant shore lines are grey.

I've only run Black Death and a QMB on one of the island maps because I've been so busy, but I'll try to give a better update with config files and a few pics.

Aviar
01-31-2008, 05:13 PM
Well, the latest Beta dll's are now out. Get them here:

http://forum.1cpublishing.eu/showthread.php?t=2613

Aviar

VW-IceFire
01-31-2008, 05:47 PM
The latest and greatest that were released today are great. Best image quality I've seen from the game since I got my 8600GTS. Flickering gone, artifacts from the previous beta DLLs gone. Nice job!

stansdds
02-01-2008, 04:25 AM
Think I'll wait until the final version is ready. Seems that dll's are being released on a daily basis as bugs are being reported.

OAC_Kosh
02-01-2008, 08:13 PM
Just installed the newest dlls. On Pacific Islands I am getting strange landmasses appearing where they didn't before.

http://img515.imageshack.us/img515/104/pacificglitchvv1.jpg

Aviar
02-01-2008, 08:20 PM
Please post your findings here:

http://forum.1cpublishing.eu/showthread.php?t=2613

Aviar

OAC_Kosh
02-02-2008, 05:08 AM
Thanks Aviar, I did now :-)

Phil_K
02-12-2008, 03:52 PM
I'm quite amazed that a set of beta files are released and nowhere inside them is an e-mail address to report errors.

I'll be f**ked if I'm going to register on yet another IL2 forum so I'll report here that I've been getting crashes with 4.09beta with the following message:

NVOpenGLPbuffer:il2fb.exe - Application Error

The instruction at "0x5ed0530e" referenced memory at "0x0000051c". The memory could not be "read".

Make of that what you will......

Urufu_Shinjiro
02-12-2008, 04:21 PM
Originally posted by Phil_K:
I'm quite amazed that a set of beta files are released and nowhere inside them is an e-mail address to report errors.

I'll be f**ked if I'm going to register on yet another IL2 forum so I'll report here that I've been getting crashes with 4.09beta with the following message:

NVOpenGLPbuffer:il2fb.exe - Application Error

The instruction at "0x5ed0530e" referenced memory at "0x0000051c". The memory could not be "read".

Make of that what you will......

Well you're f**ked then, oleg doesn't live here anymore. Crazyivan is working with maddox's graphics guy on these .dll's and they are taking the bug reports on the 1c site. No report on the 1c forum=no bug report at all. ~S~

Cobra427so
02-17-2008, 05:13 PM
Well I did the whole 4.09 update thing on my setup and now the program won't even load. I was 4.08m and everything ran fine till the update. I re-installed the 4.08m backed-up DLLs and still nothing.

Cobra427so

Phil_K
02-22-2008, 05:45 AM
Originally posted by Urufu_Shinjiro:

Well you're f**ked then, oleg doesn't live here anymore. Crazyivan is working with maddox's graphics guy on these .dll's and they are taking the bug reports on the 1c site. No report on the 1c forum=no bug report at all. ~S~

Well, no I'm not because it doesn't bother me that much, which is why I won't register. And that's the point really. Not making it as easy as possible to report bugs means that people will only report "show stoppers" and not much else. Lots of little bugs will remain.

Which kind of defeats the purpose of releasing a beta, doesn't it?

TgD Thunderbolt56
02-22-2008, 06:54 AM
Originally posted by Cobra427so:
Well I did the whole 4.09 update thing on my setup and now the program won't even load. I was 4.08m and everything ran fine till the update. I re-installed the 4.08m backed-up DLLs and still nothing.

Cobra427so

There are a couple other files that would have needed to be backed up to be able to revert back to 4.08m. If you still need them let me know.

Cobra427so
02-27-2008, 11:49 PM
Thanks TgD Thunderbolt56,

But I re-installed the 4.08 dlls and then I also tried reinstalling 4.08m, nothing seems to work. I posted over at community help, but no one has replied. As I watch on Task Manager, I can see IL2 is trying to start, it hits the CPU and memory, but never climbs over more than 50,000k or so, then just quits.

Not sure what else to do - no idea what went wrong.

Regards,
Cobra427so

MaxMhz
02-28-2008, 04:10 AM
Originally posted by Phil_K:
I'm quite amazed that a set of beta files are released and nowhere inside them is an e-mail address to report errors.

I'll be f**ked if I'm going to register on yet another IL2 forum so I'll report here that I've been getting crashes with 4.09beta with the following message:

NVOpenGLPbuffer:il2fb.exe - Application Error

The instruction at "0x5ed0530e" referenced memory at "0x0000051c". The memory could not be "read".

Make of that what you will......

Hi Phil_K - memory can not be "read" errors are caused by inproper window's memory management most of the time. It is not necessaryly an error in the I
L-2 code.

Most of the time the following freeware program that can be downloaded from Softpedia will make these errors go away: FAST Memory Defrag (http://www.softpedia.com/get/System/OS-Enhancements/FAST-Defrag-FREEWARE.shtml)

Hope this helps.

Phil_K
03-13-2008, 09:25 AM
Thanks MaxMhz! I'll check that out.

VW-IceFire
03-14-2008, 03:07 PM
Originally posted by OAC_Kosh:
Just installed the newest dlls. On Pacific Islands I am getting strange landmasses appearing where they didn't before.

http://img515.imageshack.us/img515/104/pacificglitchvv1.jpg
Get those all over the place as well. Not just the Pacific...elsewhere too.

Frequent_Flyer
03-15-2008, 07:43 AM
I beleive that is related to Global Warming.