PDA

View Full Version : Wobble weirdness solved for me maybe?



Grey_Mouser67
02-16-2006, 06:33 PM
Gang,

Had the most unusual couple of days...I fly with a Saitek X-52 and have suffered from wobbles for a long time.

The other night, while flying online, a fellow pilot said he solved his wobble problem by going into his game inputs and resetting his settings and then going into control panel and resetting them....I wasn't even sure exactly what he meant, but a Jack just got away from my spit because I couldn't hold my fire on him so I said what the heck...

Reset my settings to default, went into control panel and just moved my range of motion and deadbands back and forth...went back to the game and viola...wobbles gone! I couldn't believe it! Problem was, i was using default setting so my plane moved soooo much more slowly and the stroke was too long...so I adjusted settings in game...still good...started experimenting with zones in control panel and viola...wobbles back! Unbelievable...I've been messing with settings for the last day and was about to write a post about how I was wrong about the Mustang being improved...I was snap stalling all over the place and couldn't hit ****. I've been returning settings to default, playing with filters, dead zones, settings of all sorts and was generally hating this game again...

I then, leaving my elevator at 50, 50, 50, 55, 60, 65, 70, 80, 90, 100

I went back into control panel and slid all the dead zones back to zero....and like magic...the wobbles are gone...and that P51B...it was a whole new plane...and I Mean it! If you have the wobbles, it affects your planes stability...no doubt in my mind...I could suddenly pull on the stick and not stall, I could shoot...it is not the same game!

More experimenting to do to see if my dead zones reset...but I think there was an ever so small dead zone left in the settings in control panel and as soon as I got rid of it, I was smoothly turning...no jerking, no snap stalling....the amazing thing to me wasn't that the nose of my plane was so more stable, but it was that the plane litterally flew differently with totally different flight/stall characteristics...I can't even describe it...first time I've been wobble free in who knows how long?

edgflyer
02-16-2006, 06:41 PM
So maybe perhaps the controls need to be reset from the old patch to be able to correctly talk to the new patch. I have seen goofery stuff in past when it comes to programing. Sounds like you reset the memory. I going to give it a try and thanks for the post sir.

slo_one23
02-16-2006, 07:27 PM
i got he wobbles so what do i do ? could someone explain more detailed? im stupid

Grey_Mouser67
02-16-2006, 07:30 PM
I am speculating the problem is purely a deadzone issue...so get rid of any dead zone and filter in your game input section and go to the control panel of your operating system and right click on each of the quadrents and reset/rezero dead zone any way you can...depending on stick.

The thing that remains to be seen is if deadzone will creep back into my stick....I am as happy as a pig in do do!

I now believe that the wing snapping issue of the Mustang was directly related to this....for me, I am convinced that this is a hardware issue not something Oleg can help us with easily.

Hawgdog
02-16-2006, 09:03 PM
hey mouser, I'll try it thanks

Genie-
02-17-2006, 01:17 AM
same here..

what I have done was to set ALL joy settings to

50/55/60/....100

and.. well it works! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Cippacometa
02-17-2006, 08:32 AM
Interesting!
I'll try this evening!

Grey_Mouser67
02-17-2006, 11:48 AM
Last night, after getting rid of my wobbles...I logged onto 334th for some fast action testing...that server is good for that...strapped on a P-51B and went for a spin....

I did get bounced and killed like normal, but I scored many wounded aircraft...and get this...I out break turned Fw's, 109's and Lightnings down low on the deck when my speed was high without snap stalling on my back....amazing stuff!

I had a fw nose forward in negative g manuever and I followed him through the manuever spraying him with my pea shooters the whole way...I could never, ever hold my cross hairs on a target in negative deflection before.

No, I couldn't out turn a Spit or 109, but I could apply serious elevator while my speed was high and control my aircraft completely without losing a wing....I had manuevers and hard turns at speeds over 400mph IAS, on the deck, and did not lose my wing....no more sudden inputs means no more wing snapping!

If you are getting high speed snap stalls, wing snapping and other weird behaviors out of a Mustang, you have the wobbles...check your deadzone! I have a new game again...I'm going to be flying a whole lot this weekend!

Aviar
02-17-2006, 11:49 AM
Originally posted by Grey_Mouser67:
I am speculating the problem is purely a deadzone issue...so get rid of any dead zone and filter in your game input section and go to the control panel of your operating system and right click on each of the quadrents and reset/rezero dead zone any way you can...depending on stick.

The thing that remains to be seen is if deadzone will creep back into my stick....I am as happy as a pig in do do!

I now believe that the wing snapping issue of the Mustang was directly related to this....for me, I am convinced that this is a hardware issue not something Oleg can help us with easily.

Just wht do you mean by this??:

"...control panel of your operating system..."

Aviar

Grey_Mouser67
02-17-2006, 11:58 AM
I have an x-52...so I click on my menu button in windows and select "control panel"...in there will be some icon for "printers and other hardware" or some such category that has your joystick stuff.

Open that and look for "game controllers"...open that and you should see your joystick there. Mine is digital so there is no more "calibrating" per say....so I go into the "properties" tab and I see laid out all my rotary buttons, slide buttons, yaw, elevator, ailerons....and there is the ability to set dead zone and band size by clicking and adjusting the arrows.....now I go to elevator and right click on it and it select the "clear deadzone" option...move on to the next one and repeat etc...apply and then enter and go fly.

For me, the result was immediate...the nose still moves, don't get me wrong, but it is dampened and controllable and planes now fly straight and smooth...they used to jerk around...only the Fw, La and 109 were smooth for me.

Aviar
02-17-2006, 01:00 PM
Ok. What you are describing is your X-52 software. (If you don't have a joystick that comes with software that allows you to adjust certain settings, you won't see any of what you described.)

When I go there, I see my CH software, called CH Manager. I never go this route because I have a shortcut that takes me directly to the app.

Are you saying you had never before gone into your X-52 software to calibrate your joystick?

You are wrong when you say your joystick doesn't need to be calibrated. Ask any X-52 user. You need to go into the provided software to do that.

If this is the first time you went into your X-52 calibration app, my guess is that is where your control issues originated.

Aviar

danjama
02-17-2006, 02:22 PM
Earlier today i set my axis all to default in game and recalibrated my stick in control panel, strange, i hate to admit it but the game feels alot more solid http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif

make what you will of that, bearing in mind that i used to poke fun at the people with "wobbles"

Aviar
02-17-2006, 02:28 PM
More power to ya, big guy... http://forums.ubi.com/images/smilies/clap.gif

See you in HL.

Just let me ask you one thing, Dan. After you reset your axis to default, did you later set them back to what you had before?

Aviar

danjama
02-17-2006, 02:43 PM
Originally posted by Aviar:
More power to ya, big guy... http://forums.ubi.com/images/smilies/clap.gif

See you in HL.

Just let me ask you one thing, Dan. After you reset your axis to default, did you later set them back to what you had before?

Aviar

No i didnt im afraid it will make it more wobbly again, but see thats the thing, it feels perfect on defaults http://forums.ubi.com/images/smilies/blink.gif

I used to have it set up at 50 up to 100, now its 10, 20 etc

Aviar
02-17-2006, 02:53 PM
Yes, that's what I thought.

Ok, so all you did was adjust your in-game axis settings...in this case to default. No voodoo involved there, agreed?

Also, what Grey_Mouser67 was describing in his first post was quite a bit more involved than what you did.

Basically, you reset the axis' to default. May I suggest that the settings you had earlier were not very good for your particular hardware?

Aviar

danjama
02-17-2006, 03:03 PM
Originally posted by Aviar:
Basically, you reset the axis' to default. May I suggest that the settings you had earlier were not very good for your particular hardware?

Aviar

Its a possibility, but an unlikely one, since i had those settings for a reason, the reason being that once upon a time i changed to them and tested them and they felt great. Who knows why they became sloppier and sloppier over time, they just did.... so much to the point that i decided to take a chance and default them and recalibrate my stick....

little effort for good result

Grey_Mouser67
02-17-2006, 03:42 PM
Originally posted by Aviar:
Ok. What you are describing is your X-52 software. (If you don't have a joystick that comes with software that allows you to adjust certain settings, you won't see any of what you described.)

When I go there, I see my CH software, called CH Manager. I never go this route because I have a shortcut that takes me directly to the app.

Are you saying you had never before gone into your X-52 software to calibrate your joystick?

You are wrong when you say your joystick doesn't need to be calibrated. Ask any X-52 user. You need to go into the provided software to do that.

If this is the first time you went into your X-52 calibration app, my guess is that is where your control issues originated.

Aviar

I had a logitech Wingman extreme...an analog controller and I had a calibration function where you put it in calibration mode and spun the joystick round and round which effectively redefigned the range of motion.

With Saitek joysticks, they are digital and self center...there is NO calibration mode...be sure. And yes, it was the first time I went in there because I never messed with the joystick configurations.

The only thing you can define in the Joystick settings is range of motion and deadzone. There are click and drag sliders for these settings...when I look at the dead zone sliders, they looked like they met in the middle...grab one and they both slide away from each other equadistant. When you put them back together they "bounce" ever so slightly and leave a minute gap between them...barely perceptable. I discovered the method of right clicking on the control surface and 'rezeroing' them which put the sliders perfectly together....this is what resulted in my wobbles dissappearing.

I gave my settings above...I have messed and messed with settings, curves, linear, all at 100%, default etc....none of it helped...some were worse than others, but none made the wobbles go away.

I had a taste of wobble free flight and I was desparately trying to get it back...I was flying the same QMB mission with Mustangs over and over testing after each adjustment when I came across the right click thing....then the transformation was so startling...I was giddy almost.

Now I know why there is soooo much debate over the wobbles!

If you've never had them, or don't recognize that you do have them then none of this will make sense...so if it doesn't and you don't have anything constructive to say, mind your mother's advice and don't say anything at all.

Aviar
02-17-2006, 04:20 PM
No need to get defensive. I didn't even say anything.

It looks to me like you had a hardware problem and you solved it. What's the big deal?

If anything, your experience showed that there was no 'bug' involved....simply a hardware issue.

Aviar

partic_3
02-17-2006, 04:34 PM
This WORKED!! Wobbles Gone!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!
Sorry, got a bit over excited.
I went into the hardware/inputs section in IL2 and set all filtering and dead zones to default, then recalibrated joystick through windows and viola!!!
I don't know if it will work for everyone and I've have only flown a couple of quick missions but whoopee!!!!

VF-29_Sandman
02-17-2006, 06:45 PM
smoothed the hell outta the jug, sair, and stang. be sure. http://forums.ubi.com/images/smilies/agreepost.gif

danjama
02-17-2006, 07:45 PM
Aviar, i changed my stick settings back to my old ones and it is even better!