View Full Version : I can't finish the game

02-01-2010, 05:26 PM

I was almost finishing Assassin's Creed 2.

But, when all the assassins, including the Ezio's uncle, are in a reunion on the top of a tower, and some of the assassins burns the Ezio's finger, I think some type of bug has happened. All of the assassin's jumped from the tower, and I also jumped.

After it, the blank screen appears, and the save icons also appears. But it takes soo much time. Too much. And I have press start and finish the game, and started again. Now began my problems.

I was in sequence 14, but can't progress on the game. I had al the codex pages, and all of them was arranged correctly, making the world map. But, after I arrange the codex pages, nobody comes to talk to me. There was not nobody on the room.

I don't get to go to Rome to talk to Mario, ans so finish the game ans see the final scenes.

What I have done? I deleted the saved game and am starting AC2 again, but I am afraid that the same bug happens again. I have also cleared the Xbox 360's cache.

Could you please help me in order to this do not happens again?

Thank you for all your help

02-01-2010, 06:14 PM
I had a similar problem and even though the map with the codex pages looked correctly done it wasn't. Even though the pieces looked correctly placed Ubisoft may have had a slightly different version in mind so even though it looked correct, it might not have been "correct" to trigger the cut scene. I had to play around with mine the first time through. I remember a couple of lines going off in directions that didn't seem right, although it had to be that way. But maybe I'm wrong.

02-02-2010, 05:55 AM

The most strange thing is that when I finished the map, a sound could be heard, and I think it means that the pieces was correctly placed.

I am playing the game again, and hope this does not happens again. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

What have you done in order to finish the game, timpbader? Because after hear the sound that maybe means that the pieces was correctly placed, I can't move them anymore.

02-02-2010, 08:06 AM
I was stuck at this point for a while aswell, but like timpbader said, it was a case of thinking I had the map right but didn't. I never had a sound play and be unable to move the pieces though - once I put them in place correctly the next cutscene automatically began.

Have you placed the Apply of Eden on the pedestal thing? If not, you need to.

02-02-2010, 08:37 AM
Hello DLTyrus,

Yes, I heard the sound, what means that all the pieces was correctly positioned.

But, how to put the piece of Eden on the pedestal? I do not do this. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

How can I do this, please?

Thanks for all your help. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

02-02-2010, 09:47 AM
I think a flash or something signified the puzzle was complete and then I walked to the pedastle which triggered the rest? There's got to be videos of it up on youtube.

02-02-2010, 10:12 AM
Yes, I saw those videos.

In game I saw a flash and the sound, meaning that the puzzle was solved.

But, nothing more happened. Maybe could be a bug?

I started the game again, but I am afraid this happens again. I have cleared the Xbox 360's cache, too.

But I am afraid that don't get to finish/see the final of the game, again.

And, someone knows, regarding the Piece of Eden, how can I put it on the pedestal?

Thanks again!

02-02-2010, 11:20 AM
There's a mission/objecting marker (the glowing circle things) in front of the pedastle. You just walk into it to put apple there. If there's no marker then you've already done it.

02-02-2010, 11:49 AM
The cache has nothing to do with it. If it still doesn't work you are overlooking something.

02-02-2010, 12:22 PM
Strange, I do not see the glowing circle around the pedestal, and all the codex pages was correctly positioned.

I really don't understand where can I forgot something.

After this supposed "bug", I visited all cities, and all the objectives was completed. There was nothing more to do in the game, only the DLC Battle of Forly. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

I really does not understood what has happened.

In the case of the Piece of Eden, it must to be done after or before the completing of the codex page puzzle?

02-02-2010, 06:32 PM
Man.... you should've stay there until getting answers...
Next time after arranging the pages, walk around the pedestal many times... but it seems strange that u could leave... as u cant... well at least me before putting the PoE in the Pedestal http://forums.ubi.com/images/smilies/16x16_smiley-indifferent.gif http://forums.ubi.com/images/smilies/compsmash.gif http://forums.ubi.com/images/smilies/crackwhip.gif

02-02-2010, 08:11 PM
After this supposed "bug", I visited all cities, and all the objectives was completed. There was nothing more to do in the game, only the DLC Battle of Forly. Frown
Well there's you're problem. You have to do the Battle of Forli, aka Sequence 12, befoe you can proceed to Sequence 14.

02-03-2010, 03:38 AM
What he said. Or do you maybe have to enter eagle vision? I forget, and I'm days away from that part.

02-03-2010, 05:03 AM
@Pex3650: So, what I have to do is arrange the pages and so walk around the pedestal, until something happens?

@EzioTheAssassin: But, is it impossible to finish the game without the DLC? I think the game can be finished whithout the finishing of Battle of Forli. I think this is not the problem, sorry. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

@timpbader: I tried eagle vision, but can't see nothing useful. http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

Thank you all for all your help. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

02-03-2010, 05:44 AM
@EzioTheAssassin: But, is it impossible to finish the game without the DLC? I think the game can be finished whithout the finishing of Battle of Forli. I think this is not the problem, sorry.
as soon as you purchase the DLC and put it in the game it becomes a part of the game story meaning you have to play it before getting to memory block 14.

so any person who replays after getting the 2 DLC's will have to play all 14 blocks in order. if you have one of the 2 you will have to play it in it's place in the memory line.

if you don't want to do memory block 12 before finishing the game you need to uninstall it and download it after you have finished the game, as after you have it you need to do it as part of the story.

02-03-2010, 09:19 AM
Hello caswallawn_2k7,

Thank you for your help.

So, this means that I have to play "Battle of Forly" before arrange the codex pages and put the piece of eden on the pedestal?

Is it allowed by the game itself?

Thanks again. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

02-03-2010, 05:25 PM
So, this means that I have to play "Battle of Forli" before arrange the codex pages and put the piece of eden on the pedestal?
You can actually arrange the codex pages before sequence 14, but yes that is correct. Battle of Forli fills in sequence 12, and Bonfire of the Vanities fills in sequence 13. Once you download both DLCs, the memory will be 100% completed.

02-04-2010, 03:29 AM
I understood.

So, my mistake was not to complete sequence 12. I am trying again, and will see it, now. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

Thanks again! http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

02-05-2010, 03:08 PM
That map made my eyes bleed. You don't need the DLC to go to Rome. and to place the Piece of Eden on the pedestal, walk over to it and press B. I'm guessing you might have to do this with Eagle Vision active, but I'm not really sure.

02-05-2010, 03:37 PM
Hi silversnake4133,

Thanks. I will try again. I am now in sequence 6. http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif