PDA

View Full Version : P-40 Mirror bug?



XyZspineZyX
10-05-2003, 08:31 AM
I've noticed that with the P-40, turning on the mirror give me a total slide show. Something like 1 frame every second or so. Even the mouse reacts in a delayed manner similar to what it does on occasion when loading the mission. Turning the mirror off makes everything fine again.

I remember this used to happen on the Hurri in 1.0 as well, but I haven't tried one of those since then.

The P-47s on the other hand, work great. I use the full option (shows concrete bases in the mirror instead of grass) and have no frame rate problems at all. I have actually used it to watch bandits during scissors (which all ended in disaster, but, that's to be expected with another plane that close to your tail in *this* interpretation of the Jug. lol).

I use Direct X 9b and the latest Detonators on XP Pro with a P4.

If it was DX vs OGL, then it would behave the same across the board, yet, as I said, 3 planes (1 airframe basically) work fine, another doesn't (possibly 2 airframes).

Anyone else notice this?

XyZspineZyX
10-05-2003, 08:31 AM
I've noticed that with the P-40, turning on the mirror give me a total slide show. Something like 1 frame every second or so. Even the mouse reacts in a delayed manner similar to what it does on occasion when loading the mission. Turning the mirror off makes everything fine again.

I remember this used to happen on the Hurri in 1.0 as well, but I haven't tried one of those since then.

The P-47s on the other hand, work great. I use the full option (shows concrete bases in the mirror instead of grass) and have no frame rate problems at all. I have actually used it to watch bandits during scissors (which all ended in disaster, but, that's to be expected with another plane that close to your tail in *this* interpretation of the Jug. lol).

I use Direct X 9b and the latest Detonators on XP Pro with a P4.

If it was DX vs OGL, then it would behave the same across the board, yet, as I said, 3 planes (1 airframe basically) work fine, another doesn't (possibly 2 airframes).

Anyone else notice this?

XyZspineZyX
10-05-2003, 09:07 AM
I have the same problem and so does a friend I play online with. It would bug me if I actually flew the P-40. I figure it is a known issue. If it is correctable I would like to know but I just figured it was one of the little quirks in the game that won't be fixed.

XyZspineZyX
10-05-2003, 09:08 AM
The mirrors in the Hurri and P-40 have a problem with S3TC compression. Disabling compression will make the mirrors work properly, but at a fps loss.

I hope this gets fixed eventually, as most ppl play with S3TC enabled.






Message Edited on 10/05/0302:09AM by StG77_Fennec

XyZspineZyX
10-05-2003, 03:20 PM
Same problem with the La-7. Again, no problems on the P-47.

http://freespace.volitionwatch.com/icefire/icefire_tempest.jpg
"Never in the field of human conflict was so much owed by so many to so few." - Winston Churchill

XyZspineZyX
10-05-2003, 04:55 PM
Of course, as long as we have this unrealistic sound in the cockpit we don't really need mirrors. /i/smilies/16x16_smiley-very-happy.gif