View Full Version : i cant get sage trophy...please help

01-01-2012, 05:22 AM
i worked my *** off getting those books and when i finally got the last one i didnt get my trophy. i head it was due to the new update.

can some one give me advice on how to get the trophy.

its the last one 1 need to get platinum

01-01-2012, 06:33 AM
The Achievement is broken for the XBox as well. I'm sure they know about it, the question is can it be fixed without having to replay the game.... which I'm not about to do.

01-01-2012, 02:40 PM
This is a known issue. Please make sure you contact Ubisoft Support by following the link in my signature. Let them know the exact details and what Platform you are playing on.
Thanks http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif

01-01-2012, 02:59 PM
This is all you have to do.

This exact same way, sadly you might have to do the whole game again if you havent yet got all the books.

http://forums.ubi.com/eve/foru...1069024/m/8411081479 (http://forums.ubi.com/eve/forums/a/tpc/f/5251069024/m/8411081479)

01-01-2012, 04:05 PM
If you got all the books then your screwed. This is due to the 1.02 patch and a known glitch but Sony and Ubisoft seems to think its ok still have the update live.

Deleting the patch will not help with this achievement/theophy.

I find it very disrespectful to the fans and players that ubisoft has still not made an apology or even an acknowledgment of their mistake.

01-01-2012, 05:17 PM
Please read my post above for details.
Thanks http://forums.ubi.com/images/smilies/16x16_smiley-wink.gif

01-02-2012, 12:11 AM
i did it

i deleted the update and stayed offline
and replayed the story >http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

but i got my platinum trophy http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif