View Full Version : im stuck! please help! i think my game might be glitched

11-23-2009, 06:47 PM
im stuck at the part where you play as Desmond, in the warehouse and after u you show off your athleticism to lucy he faints and dreams hes the assassin from the first game. u chase your target in the dream to this tower. it says clime it but ive made it to the first balcony on this tower after that i cant find a path to get any higher. please help becoase i think my game is glitched

11-23-2009, 06:51 PM
i dont the game is glitched...i am having the same problem. i have searched all over that city and tried to climb the tower. after a little while, the door opens and the target is gone

11-23-2009, 06:51 PM
you have to get up to that small ledge then try to grap the poll hanging above it then from there you can make it to the top.

11-23-2009, 06:54 PM
Im in the same boat as you.....

11-23-2009, 06:55 PM
frome the balcony there is no way up it wont let me grab the light post above it

11-23-2009, 07:01 PM
ok i just made it...after the target gets in the room. get on the wall on the right...run along that wall towards the tower, like you are trying to jump on the first ring. assassin will go to the left just keep holding down the RT and A. he will grab the first ring and climb up

11-23-2009, 07:05 PM
ive done that it gets me to the first balcony the balcony im having problems with

11-23-2009, 07:10 PM
get on balcony wall and jump from side to side, it will grab the light post...he meets the girl at the top and they make out,lol. then he wakes up

11-23-2009, 07:19 PM
http://forums.ubi.com/images/smilies/51.gif are you people seriously having trouble with this, its so simple, just look around, remember you can run up a wall and jump sideways, it isnt glitched, a glitch would be like you cant hold onto a ledge, not a missing ledge, its really simple, just youtube it or keep trying

11-23-2009, 09:06 PM
Yeah I dont get why people are having trouble with this, it is the exact same tower you climbed in AC1.

11-23-2009, 09:23 PM
ugh...i had this problem for some time...i thought i missed something...

...then i remembered you can jump strait up...if you have a ps just hold down R2 n push and release X n u jump straight up...
...grabbing the ledge above you http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

11-24-2009, 10:02 PM
That's a great tip! I just did it after being stuck on that balcony for what seems like forever! Just perched on the outmost ledge of the balcony, faced the beam, R1 + X and bam! I was up. THANKS!

11-25-2009, 07:36 AM
yeah, this one got me for a while. I finally perched on the left hand ledge, held RT and A (to jump up). When he jumped I pushed the stick to the right and he finally made it into the post above the door.

11-25-2009, 09:26 AM
Well...I am glad that is solved.

On to the next item up for bid.

11-25-2009, 02:17 PM
to mines definitly glitched if i touch the light more than once it disappears or freaks out and gets stuck in the wall. glad the jump straight up works

11-25-2009, 02:50 PM
nope, it happened in the first game too, it was creapy when i first saw it but then turned out to be hilarious, it looks like a spinning ufo