View Full Version : X45 Question for Tully

12-12-2004, 01:40 AM
Hello Tully,

Need some advice on Saitek X45:

My setup:

MSFF2 as yoke.
Saitek X45 Powerlever for engine management.
Saitek X45 yoke connected but hardly used.

Driver Saitek SD_winnt_4_3_3_1727

My problem:

Gear worked fine until one day with IL2FB Ace EXP I got 3-4 secs intervals between input and result. Firstly only online, later also offline.
For instance, between SETTING takeoff power on the X45 and GETTING takeoff power in the game would take 3-4 secs,
ofcourse in all flight regimes also in a dogfight...
Also other buttons with different functions on the X45 same effect. MSFF2 always worked fine.
After upgrading to PF problem gone... only to come back even worse, even calibrating in PF control menu hard (keep button pushed for 6-8 secs before its assigned)

Flying with MSFF2 only, to painfully discover that my left arm is too short for all functions.

Any ideas?

Cheers, trebby0

12-12-2004, 02:44 AM
Does the same delay exist in Windows Controller properties or other games?

Are you using built in USB ports, an expansion USB card or a powered hub?

12-12-2004, 07:52 AM

No, I'm not Tully (but I think I could play him on TV http://forums.ubi.com/images/smilies/25.gif ), but I've experienced similar problems before and "dollars to donuts", it's probably the profile you are using not playing nicely, either with itself or with your other controls. The ".dat" file is not condusive to display, however.

To test this theory will take about 10 minutes of your life, but you'll start narrowing it down. Try making a backup copy of your controls settings file for IL2 (I forget the filename at the moment), as well as your profiles for the X-45 and maybe the MSFFB2 stick (I assume they have something). Unplug all of your controls, open your Controls window in game, and reset it to Default. Next, quit out, plug in the X-45, and open the Controls window in the game. Assign the throttle control in the HOTAS section if it doesn't do it automagically for you. Fly with ONLY the X-45 plugged in and see if it's working. Try loading the profile for it for the Saitek software. Is it working? If it is, repeat the entire process with ONLY the MSFFB2 stick and without the X-45. Does the MS stick work by itself? Then, with its own profile?

Now, plug both in with the profiles for both OFF. Make sure you know which one assigned the Throttle in the Controls area of the game. Does it work now? If it works fine, you probably have a conflict with your profiles (which you don't have activated).

Try that, and let us know what happens. The profile stuff would be impossible for me to test without the MSFFB2, but I could look at your X-45 profile for internal conflicts.

Hope that helps.

* _54th_Speeder *