View Full Version : Weapon wheel problems

03-23-2011, 08:36 PM
I don't know if anyone else has had this problem, but I can only change weapons by assigning it to one of the hat switches, merely selecting will not work. I select it the picture of the weapon pops up for a frame or two and then it reverts back. It has worked once or twice, but it is getting really annoying. I contacted ubi support and they told me to check the manual or the forums. The manual basically told me I was doing it right. Is it different than AC2 or do I have a unique problem.

By the way I am using a gamepad F310 in direct input mode which worked fine for AC2 and is otherwise working fine in ACB

03-23-2011, 09:46 PM
Never mind the problem fixed itself.

03-23-2011, 10:56 PM
K it's back, I think it has something to do with me changing set ups, when I change them it takes a while for it to work properly again

03-24-2011, 02:09 PM
Nope, that's not it. It now works more often, but still infrequently, help?

03-25-2011, 05:08 PM
i have the same problem. do you have any solution?

03-25-2011, 05:37 PM
i have the same problem. do you have any solution?
No, I have pretty much given up and am now only using the hat switches. Picking different items to select seemed to help. After it eventually worked it would continue to do so until I used a hat switch again. I could never find a pattern of when it actually worked for the first time though. If anyone actually knows a solution it would be very helpful, because right now its one system or the other.

Trying to find similarities, do you use a controller? Did you install it off a disc? Have you changed the default hat switches?

Another theory I have, in the first sequence in Monteriggioni, when you were escaping, it brought up a prompt to select your pistol via the weapon wheel. Did you do that? Did you then kill the guard holding the girl hostage with it? I didn't because I had used up my ammo. Maybe that has something to do with it. Probably not, but when I went back to try that memory again to see if it told me anything useful it switched first try. Fluke or connected? No idea.

03-26-2011, 05:34 AM
yes i use a controller. i use ps3 dualshock controller with MotioninJoy tool. that means we both installed a driver. i changed the hat swithes yes, but changed back to default again. and also i didn't use my pistol back there. but i don't think this is the problem because my brother had the same problem even in the begining of the game.

when i try keyboard controller it works perfect.

did you search different forums?

04-06-2011, 08:26 AM
i am experiencing the exact same problem, and its getting mildly annoying http://forums.ubi.com/groupee_common/emoticons/icon_frown.gif

04-07-2011, 07:19 AM
Hi have the same issue with my logitech Cordless Rumblepadô 2 but is work ok with my oder logitech wireless Gamepad F710

04-08-2011, 08:03 AM
I have same problem. I`ve changed controls but no result. Weapon is not changing at all and I can use only this 4 basic types like sword, medicene/ fists and so one...Even when i`m trying to chose a poisoned blade it has no reaction at all. I belive that there is some bug or problem with this last patch but i`m not sure cuz I didnt play the game with old patch. Did enyone had this problem using old patch?

04-09-2011, 03:29 AM
Had this prob. from day 1.Already completed game. Started again 3 days ago, new patch (1.02) installed automatically. Have had more problems second time round. Ezio disappears(twice so far), jumped on to a roof and got stuck up to my waist( had to restart), white and black screens a few times. Don`t get me wrong i love the game, but there are to many glitches. Lags in some parts of game, plus all the above problems. But i`m hoping ubisoft may address some of these, if not all. My biggest problem is i don`t seem to be able to access the Di Vinci Disappearance. Tried Uplay, can`t find any Help for PC.

01-29-2015, 10:33 PM
Change gamepad X & Y sensitivity to 10 (standard is 6 and it cause problems)
I'm using 2$ china pad and it works :)