View Full Version : Can anybody help me, in regards to an irritating glitch?

12-16-2011, 09:28 AM
Hello, I purchased Assassin's Creed: Revelations the day it was released, and found it thoroughly enjoyable. I completed it, and it is no doubt brilliant.

However, when I was replaying a memory (I think it was 'A little errand' or 'A portrait of a lady') I exited the replay during the opening cutscene, in which Ezio had his hood down.

When I had returned to the normal aspect of the game,Ezio's hood was down, and has been ever since.

I am able to place his hood back up, but only by changing into one of the unbreakable sets of armour(Ishak Pasha's or the Master Assassin armour)or if I go to Cappadocia, but I prefer to stay with the Azap, Mamluk, and Sepahi armour sets. When I change into the aforementioned sets, Ezio's hood is down, and this is starting to irritate me.

Could anyone who comments on this post offer me a solution, in restoring his hood but keeping the Azap/Mamluk/Sepahi armour equipped? I have tried dying the clothes as well, and replaying cutscenes, but these attempts have not worked.

I ask readers to forgive and alert me of any genuine spelling mistakes, and I ask American/Canadian readers to forgive any words that have been 'Anglicised' (spelt in the English manner, as opposed to the North American variant of English), as this is my first time on the Ubisoft forums.

Thank you!

12-16-2011, 09:30 AM
replay the mission again and accept it.

12-16-2011, 09:47 AM
It worked, thanks mate!

12-16-2011, 03:21 PM
you are welcome dude http://forums.ubi.com/groupee_common/emoticons/icon_wink.gif