View Full Version : A myriad of issues; one after another... [Brotherhood]

06-03-2011, 05:54 PM
I bought Brotherhood this week, during the Steam sale.

And I'm honestly starting to regret it.

Don't get me wrong, it's an amazing game. On consoles. The PC version, however, has been nothing but a huge problem. Let me start with a list of issues...

* First, the game and menu ran at about 5fps. I knew this couldn't just be my PC, because I ran AC2 maxed out at 60fps.

My specs were:
- Phenom II x4 965 Black Edition 3.2ghz
- 4GB DDR3-1600 RAM
- Radeon HD5770 1GB GPU

After toying around with it for about an hour, I realized it might be a processor issue. I set my core affinity to CPU 1 and CPU 0, and it evened out. I finally realized that if I turn all core affinity OFF, then back on (IE; Check "All Processors" and then re-check it.) it works fine. 60FPS, no issues. This just annoys me senseless, because I have to do this EVERY TIME I START THE GAME.

* I figure "Hey, lets see how well Multiplayer works now that I have the game running right."

First, I realize the "Multiplayer" and "Uplay" buttons are greyed out. Ok, I'll check them. Multiplayer sits on "Please Wait", then hits me with... "The Ubisoft server could not be reached at this time, try again later."

This continues everytime I try. I find out on these forums it might be a port forwarding issue. I open my router, and forward port 7917 and such, and restart my router, the game, my PC... Nothing.

I find out it might be a "Hosts" file issue. I delete my hosts file and keep a backup. Restart game, PC, etc... Nothing. Still grey, still no multiplayer.


At this point, I'm at my wits end. I cannot figure out a permanent solution to the speed/core affinity issue, and I STILL can't play multiplayer. Is there a fix I'm missing? Is something just hiding from view?

I'd appreciate any help, because I'm starting to feel like I wasted $30.

06-03-2011, 06:23 PM
check this out may be helpfull http://forums.ubi.com/groupee_common/emoticons/icon_biggrin.gif

http://forums.ubi.com/eve/foru...831048829#1831048829 (http://forums.ubi.com/eve/forums?a=tpc&s=400102&f=2361024388&m=8421017829&r=1831048829#1831048829)

06-03-2011, 07:47 PM
Tried everything in that guide, as well as the stickied one in this forum.

No luck.

All ports open on my router's setup screen, in Windows Explorer's router settings, and in Windows Firewall's settings. No dice.

06-03-2011, 10:36 PM
The multiplayer part of the game is so god damned glitchy, it's unbelievable. It is not your system, it is the game. It does this for everyone, no matter what suggestions you take from Ubisoft. You basically did what the rest of us asshats did; we spent money on a lemon. And Ubisoft is rolling over in our dough, laughing at the idea that it just conned a bunch of consumers into buying a product that is about the quality of scott's toilet paper.

The multiplayer part of the game has been glitching since ACB has been out---you go to kill the NPC and it freezes your system, then people get stuck in the spots they stood in until the match ends, you get logged out at the end of a match and you don't get the points you earned, the NPCs end up on the other side of the map when you start walking toward them. Just ridiculously crazy issues. I've never seen a game so incredibly glitchy and unprofessionally put together.