View Full Version : cant go on i am stuck

04-16-2011, 04:28 AM
in the auditore cript i cant release from the plank i swam true the water to join the women i climb up the planks to go sideways along the planks.

when i am on the other side and have to release to pull the lever i cant let go from the plank to drop down i tryed everything but he wont let go and i keep hanging on the plank.

is there a special thing or a specific place i have to let go because i just keep hanging there.

04-16-2011, 05:25 AM
Sorry, i have no idea where you are (a picture would be great), as i can't remember...but maybe it's a glitch or bug if your drop command isn't working just in that one place. Have you tried to drop from anywhere else in there?

04-16-2011, 06:48 AM
No, there is nothing special there. Once you clear the fence that's blocking the area (the reason you have to climb over), pressing the "B" button (the right button) on the controller should have Desmond let go so he can drop down.

04-16-2011, 08:04 AM
OK thank you but i am playing this game on the PC with the keyboard/mouse but i don't think that makes a difference to the answer i think it is a fold in the installation then because i have tried every key and of combination.

one of those thing i guess i try a reinstall and save the save games i guess don't now what else to try but thanks for your trouble.

04-16-2011, 08:10 AM
well thank you for your reply buti think i had the answer already i should have be abble to drop there with no trouble so yes i think it is a glitch/bug because i have dropped from many places before here.

picture is going to be difficult because i have just uninstalled to try if that fixed it.