PDA

View Full Version : Major Discrepancy on CONTROLS



punkbrutus
07-21-2011, 02:10 AM
PC controls are so difficult. Camera panning during combat or when operating machines were annoying.

Love the game, but it's just hard to use controls. Game pad/USB Game Controller options would be helpful in PC.

GallopRider
07-21-2011, 08:41 PM
I've played all the games from AC1 to ACB on my PC with a Microsoft Wired XBox 360 controller. Works like a charm. Never tried any other brands, but I'm pretty sure you could get them to work. If the game itself doesn't have a setting for non-Microsoft gamepads, then you could download "Joystick 2 Mouse" and configure that to your liking.

Mr_Shade
07-22-2011, 04:39 AM
Indeed http://forums.ubi.com/groupee_common/emoticons/icon_smile.gif

I would suggest considering looking into the Wired Xbox 360 pad - you can use one from the Xbox, so you can find those cheap - or even second hand.

You will need to download the driver for the pad, but that's easy to find on the MS site.

Using the Xbox 360 pad - may help you a lot, since the game was written to fully support that.

The wireless Xbox 360 pad, and the PC adapter needed, may work ok as well - however some people have reported problems with the triggers.

So I would suggest the wired Xbox pad - I paid 7 for mine onlinehttp://forums.ubi.com/groupee_common/emoticons/icon_wink.gif

TheLeoCrow
07-22-2011, 01:20 PM
I got a really cheap no-name controller and it works perfectly with the game. i remapped the keys to suit my liking through the game itself

I should also note that many other games like "darksiders" and "star wars: the force unleashed" need a third party software to make any NON xbox 360 controller to work. So Ubisoft has done a good job on the controls in my opinion.

I have mostly played the games with keyboard and mouse because i am more used to that and i didn't have much problem there either (most of my problems were with the camera, not the controlls themselves)

Godwhacker
07-28-2011, 12:43 PM
I had much the same problem- it's alright for the most part, but it makes some of the free-running sections extremely fiddly.

The main problem I had was on the mission 'Liquid Gold'- you get a series of jumps after giving chase to the Captain that are extremely difficult using a keyboard, since the direction you have to jump isn't either straight up, down, left or right, or a diagonal.

You can do it if you take the time to line up the jump, but there's a very good chance that the Captain will shoot you whilst you're doing it.

And then you will fall to your death. And then you have to do it all again. I just gave up at that point.

I remember the 'Young at Heart' Thief sidequest being a total ***** too.

thornebrook
07-28-2011, 01:22 PM
I'm with TheLeoCrow, no real problems with the keyboard+mouse combo as well. Once you get used to it, it's actually quite intuitive and comfortable. Except during the fixed camera sessions in Liquid Gold, as mentioned by Godwhacker.

Recently though, I caved and bought a 360 controller because I keep hearing how the controls are much better. It's been a rocky road adjusting to it. I much prefer the controller now for Single Player, but holy crap, for Multiplayer? Locking with the thing and moving the camera was just way too stilted for me. If anyone has any tips on how to adjust to it from the keyboard+mouse combo, I'm all ears, since I did buy it for MP after all. I think my main issues with it are the difficulty in locking, the awkward camera, and how just simply moving in a straight line ahead is so difficult for me (forward seems to be relegated to this one tiny spot north of the left stick -- the slightest nudge to the left/right of that makes the character swerve).

After several days of trying to adjust to it in MP, I had to throw in the towel and shift back to my mouse and keyboard (new-found appreciation for both now, haha).

Also, for those having trouble with moving the camera using the mouse, check that you don't have any button-reassignment programs turned on (like X-Mouse Button Control), and go to in-game Options and turn up X-AXis and Y-Axis sensitivity. Made things so much better for me.