PDA

View Full Version : Water...not the same.



Fighterduck
03-26-2005, 01:43 PM
ok, i had to reinstall all my pc software included PF....and now...what a S***** of water! I tried to change water setting 0,1,2...but nothing!
what i'm doing wrong! before reinstall, the water looked really good and now....bha..all it's flat and not dinamic.

I have a sapphire radeon 9800 pro with cat 5.3

VW-IceFire
03-26-2005, 02:42 PM
Take a breath for a second and then do this.

1) Click Start > All Programs > UbiSoft > FB+AEP+PF (or just PF) > Setup

Check that OpenGL is selected and Use Stencil Buffer is on.

2) Start the game

Go into video settings. Make sure all settings are set at Excellent. For landscape settings, click that category and select Perfect as a custom setting.

All good from there on out. In the config ini, you can now set water 0, 1, and 2 (3 doesn't work on your card, nor mine).

Fighterduck
03-26-2005, 02:45 PM
but i have to use openGl or DX?

Cess-SGTRoc
03-26-2005, 03:10 PM
Open GL for perfect , and for the water setting you are wanting.

JunkoIfurita
03-26-2005, 06:44 PM
Actually, you may also want to check that HardwareShaders has a setting of 1 in your OpenGL section of the conf.ini

I had a similar annoyance for a long while with this game...for some cards, the conf.ini defaults that setting to zero, meaning you're not getting pixel shader'd water.

Then set the water= setting to whatever your card can handle.

----

ReligiousZealot
03-26-2005, 11:17 PM
I run a ATI 9600 with Catalyst 4.1 drivers, and these are the conf.ini settings I used to get the ultimate performance out of the game on my rig. I spent about 3 hours changing these variables till I got it to do what I wanted...and oh yeah, I used the cat drivers to force 4x anti-aliasing on at all times...gives the game an unbelievable smooth/realistic look (I've gotten my friends to say "Holy S***!").

Granted, I do have the in-game PF settings on perfect, this is what I tweaked (with the aid of PFCoastie's guide), surprisingly, trees still look good even under these settings.

HardwareShaders=1

Shadows=0
Specular=1
SpecularLight=0
DiffuseLight=0
DynamicalLights=0
MeshDetail=2
VisibilityDistance=3

Sky=1
Forest=0
LandShading=0
LandDetails=0

LandGeom=2
TexLarge=0
TexLandQual=0
TexLandLarge=1

VideoSetupId=17
Water=1
Effects=0
ForceShaders1x=1

PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0

Fighterduck
03-27-2005, 02:06 AM
I never notice the difference on water 1 or 2..is so different?

Fighterduck
03-27-2005, 02:14 AM
what the...!
i seto openGL on the setup menu..OK, i close it then i reopend it and...DX another time...seem thar i can't activate open gl

Fighterduck
03-27-2005, 02:22 AM
ok, if i activate opengl in the game it work..but the water look a litle different than before. But don't know if it is better or not.
Anoyne can post screens of what the water looks like in your game?

my .ini settings are :
HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=3
Water=2
Effects=2
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

....can i do something?

Grue_
03-27-2005, 04:15 AM
http://www.airwarfare.com/sturmovik_101/faq_index.htm#074

Try the relevant section of this rather excellent guide.

JunkoIfurita
03-27-2005, 04:30 AM
Your setting seem ok...I don't run an ATI card so I can't be sure.

The only difference between water=1 and water=2 is in the reflections of planes/objects in the water. If you've got it running right with reflective water, in water=1 you'll just see a pure reflection of your objects - in water=2 you'll get wavy reflections, refracting over the waves. I think it looks pretty neat ^_^.

But then I'm only running a FX5700LE, so my frame rate goes through the floor if I try to use anything but ForceShaders1x. My water is nowhere near as pretty http://forums.ubi.com/images/smilies/cry.gif

----

Fighterduck
03-27-2005, 05:08 AM
aaaaahaaaa...i see.
So i think that the water that i see now in the game it's the best that i can have with a Radeon 9800 pro.
Uff...sory for this "another" water discussion. But i was surprised to find a different effect that the one i had before.

thanks!