PDA

View Full Version : 4.07 planes in DGEN campaigns



Rammjaeger
12-29-2006, 06:16 AM
Greetings everyone,

I've tried to add the new flyable japanese planes in IL-2 1946 to the DGEN plane list and I've found that I can add the N1K2 Shiden-Kai to the IJN fighter campaign (1944-45) + the Ki-43-II and Ki-43-II Kai to the IJA fighter campaign (1942-45 and 1943-45 respectively) but I couldn't add the Ki-27 to the IJA fighter campaign (1941) and the J2M5 to the IJN fighter campaign (1944-45). What I mean is that they appear on the plane list when I open the campaign in the game but the campaign won't load if I select them.

Can anyone tell what the reason is? Thanks.<div class="ev_tpc_signature">

"At last we are eye to eye with death. We must renounce all hopes of freaks and fortunes. Sacrifice to the last drop of blood is demanded of us. Surrender would paralyse and sap our race for generations." - Wehrmacht radio broadcast to German troops in Hungary, October 1944

mortoma1958
12-29-2006, 02:46 PM
The reason why is that the former planes were already AI planes and so the Dgen program ( for generating the default campaigns ) recognizes them. But the new planes are not yet recognized by Dgen because the author of Dgen is Vadim "Starshoy" Kolosov has not added them yet. He does not work directly for 1C in Russia. He is solely a contributor to the series, therefore his latest updates are not always in the games/updates/patches.

He will have to do some reprogramming to the Dgen executable and recompile it so it will recognize the latest planes. This no doubt will be forthcoming and the best place to keep tabs on when this new Dgen.exe file will come is by checking into www.simHQ.com (http://www.simHQ.com) from time to time.
The people over there are the first to be on top of such developments. Go to the IL2/FB forum. Check out the posts in there that mention Dgen. You will have to wait until it's available and then DL it, then replace the old file with the new one.

Rammjaeger
12-30-2006, 03:10 AM
Originally posted by mortoma1958:
The reason why is that the former planes were already AI planes and so the Dgen program ( for generating the default campaigns ) recognizes them. But the new planes are not yet recognized by Dgen because the author of Dgen is Vadim "Starshoy" Kolosov has not added them yet. He does not work directly for 1C in Russia. He is solely a contributor to the series, therefore his latest updates are not always in the games/updates/patches.

He will have to do some reprogramming to the Dgen executable and recompile it so it will recognize the latest planes. This no doubt will be forthcoming and the best place to keep tabs on when this new Dgen.exe file will come is by checking into www.simHQ.com (http://www.simHQ.com) from time to time.
The people over there are the first to be on top of such developments. Go to the IL2/FB forum. Check out the posts in there that mention Dgen. You will have to wait until it's available and then DL it, then replace the old file with the new one.

OK, I see. Thx for the info. Is there any chance of this being corrected in the supposedly upcoming 4.08 patch?<div class="ev_tpc_signature">

"At last we are eye to eye with death. We must renounce all hopes of freaks and fortunes. Sacrifice to the last drop of blood is demanded of us. Surrender would paralyse and sap our race for generations." - Wehrmacht radio broadcast to German troops in Hungary, October 1944

Antoninus
12-30-2006, 10:07 AM
Have you tried the new Dgen.exe 4.0.6.11 posted in Ian Boys thread at simhq? It should contain all new 4.06 planes.

http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb....c;f=144;t=006070;p=1 (http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=144;t=006070;p=1)<div class="ev_tpc_signature">

_____________________________________
http://img136.imageshack.us/img136/3734/il2sig26hf.jpg

Actually everybody talks about aerial combat. I maintain that hitting ground targets, and especially ships is more dangerous than aerial combat. - Joe Foss

Rammjaeger
12-30-2006, 12:23 PM
Originally posted by Antoninus:
Have you tried the new Dgen.exe 4.0.6.11 posted in Ian Boys thread at simhq? It should contain all new 4.06 planes.

http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb....c;f=144;t=006070;p=1 (http://www.simhq.com/simhq3/sims/boards/bbs/ultimatebb.php?ubb=get_topic;f=144;t=006070;p=1)

Yes, it adds new Burma campaigns. Thanks a lot for the link! Still can't fly the Ki-27 in the IJA campaign though.<div class="ev_tpc_signature">

"At last we are eye to eye with death. We must renounce all hopes of freaks and fortunes. Sacrifice to the last drop of blood is demanded of us. Surrender would paralyse and sap our race for generations." - Wehrmacht radio broadcast to German troops in Hungary, October 1944

mortoma1958
12-30-2006, 02:45 PM
Originally posted by Rammjaeger:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by mortoma1958:
The reason why is that the former planes were already AI planes and so the Dgen program ( for generating the default campaigns ) recognizes them. But the new planes are not yet recognized by Dgen because the author of Dgen is Vadim "Starshoy" Kolosov has not added them yet. He does not work directly for 1C in Russia. He is solely a contributor to the series, therefore his latest updates are not always in the games/updates/patches.

He will have to do some reprogramming to the Dgen executable and recompile it so it will recognize the latest planes. This no doubt will be forthcoming and the best place to keep tabs on when this new Dgen.exe file will come is by checking into www.simHQ.com (http://www.simHQ.com) from time to time.
The people over there are the first to be on top of such developments. Go to the IL2/FB forum. Check out the posts in there that mention Dgen. You will have to wait until it's available and then DL it, then replace the old file with the new one.

OK, I see. Thx for the info. Is there any chance of this being corrected in the supposedly upcoming 4.08 patch? </div></BLOCKQUOTE>I doubt it any new Dgen versions will appear in any of the official patches. New versions of Dgen.exe have not been included with official updates or patches since PF came out. Any Dgen updates have had to be seperately DL'd from other sources since then.

Problem is mostly due to Starshoy taking a long time to update the executable every time a new plane or two ( or more ) appears in patches and updates. He simply cannot keep with this series any more so the new executables are weeks or months late. He is working more on the campaigns
engine for BOB/SOW, that's where most of his concentration has been.